Página 1 de 3

[SOLUCIONADO] CPC 464 recién comprado. Duda transformador

Publicado: 29 May 2018, 15:06
por GUSS
Muy buenas foreros.

Acabo de adquirir recientemente un Amstrad CPC 464 para mi modesta colección. Es mi primer 464 y aunque siempre he tenido mucha relación con él (mi primo tenía uno y un amigo también con el que jugábamos horas y horas) nunca había tenido ninguno.

El ordenador funciona (enciende la placa con el Basic) pero el cassette le falta la goma. En principio no es problema conseguirla, hay bastantes tiendas que la venden. Pero la duda que me surge es la siguiente:

Además del 464 tengo un 6128 que compré hace tiempo y me vino con un transformador 5V y 12V con el que funciona correctamente. Si conecto el 464 a la toma de 5V de este transformador funciona sin problemas. Pero como tengo varios sistemas (Spectrum +3, master system, game gear, etc..) para no ir teniendo que enchufar y desenchufar su correspondiente trasnformador, me hice un transformador universal a partir de una fuente de alimentación de PC.

Todo lo que conecto a esa fuente funciona sin problemas (incluido el amstrad cpc 6128), pero el 464 que acabo de comprar no se enciende cuando lo conecto a los 5V de la fuente (el mismo conector de 5V con el que conecto el 6128 que sí que va)

Se supone que la fuente de PC tiene amperios de sobra, lo único que se me ocurre es que necesite algo más de 5V por el tema del cassette (el transformador del 6128 da 5,21V y la fuente de PC da 5,1V medido con el tester).

¿Alguien sabe por qué puede ocurrir esto?

Gracias!!

Re: CPC 464 recién comprado. Duda transformador

Publicado: 29 May 2018, 15:12
por duca750
Hola. No acabo de entender el problema, en principio da igual 5v que 5,2, mientras haya intensad todo perfecto. Ponle la goma nueva y debería ir perfectamente.

No será que el conector no tenga el diámetro adecuado?

Re: CPC 464 recién comprado. Duda transformador

Publicado: 29 May 2018, 16:00
por jjsaenz1969
A partir de 4.9v no deberías tener ningún problema.

Re: CPC 464 recién comprado. Duda transformador

Publicado: 29 May 2018, 16:54
por mrbyte
Supongo q la polaridad la tienes en cuenta, pq asi de pronto se me ocurre q el gomas y la game gear tienen la polaridad contraria.

Saludos

Enviado desde mi Metal mediante Tapatalk


Re: CPC 464 recién comprado. Duda transformador

Publicado: 29 May 2018, 22:19
por GUSS
Buenas.

Gracias a todos por vuestra colaboración. A ver si me explico un poco mejor.

La duda es que el 464 funciona perfectamente con un transformador de 5V y sin embargo, si lo conecto a una fuente de PC (a la línea de 5V y respetando la polaridad, por supuesto) el ordenador no se enciende. Y no logro entender porque.

Me gustaría poder utilizar la fuente de PC porque ahí tengo todos los conectores de todas las máquinas que uso bien diferenciados y etiquetados y así no tengo que ir quitando y poniendo trafos cada vez que quiero cambiar de maquina.

Quería preguntarlo por si estaba pasando algo por alto.

Gracias

Re: CPC 464 recién comprado. Duda transformador

Publicado: 30 May 2018, 18:05
por Apronics
Pues, por lanzar otra hipótesis diferente... a ver si va a ser por el conector, es decir, el CPC funciona, la fuente funciona, pero juntos no funcionan: podría ser que el polo central del conector de alimentación no esté haciendo contacto de modo que lo insertas y parece conectado, pero en realidad, sólo lo hace en la parte exterior y no en la interior porque se quede flotando sin hacer contacto por ser demasiado fino para la hembra. Puede ser tan simple como eso. No sería la primera vez que veo algo así.

Re: CPC 464 recién comprado. Duda transformador

Publicado: 30 May 2018, 22:14
por duca750
Apronics escribió:
30 May 2018, 18:05
Pues, por lanzar otra hipótesis diferente... a ver si va a ser por el conector, es decir, el CPC funciona, la fuente funciona, pero juntos no funcionan: podría ser que el polo central del conector de alimentación no esté haciendo contacto de modo que lo insertas y parece conectado, pero en realidad, sólo lo hace en la parte exterior y no en la interior porque se quede flotando sin hacer contacto por ser demasiado fino para la hembra. Puede ser tan simple como eso. No sería la primera vez que veo algo así.
Efectivamente, si la fuente va, y el cpc va, yo también pienso que el conector no es exactamente igual.

Re: CPC 464 recién comprado. Duda transformador

Publicado: 30 May 2018, 23:16
por Apronics
duca750 escribió:
30 May 2018, 22:14
Apronics escribió:
30 May 2018, 18:05
Pues, por lanzar otra hipótesis diferente... a ver si va a ser por el conector, es decir, el CPC funciona, la fuente funciona, pero juntos no funcionan: podría ser que el polo central del conector de alimentación no esté haciendo contacto de modo que lo insertas y parece conectado, pero en realidad, sólo lo hace en la parte exterior y no en la interior porque se quede flotando sin hacer contacto por ser demasiado fino para la hembra. Puede ser tan simple como eso. No sería la primera vez que veo algo así.
Efectivamente, si la fuente va, y el cpc va, yo también pienso que el conector no es exactamente igual.
¡Ostras!, teniéndolo en la cabeza, y no había interpretado que estabas diciendo lo mismo que yo estaba pensando. Disculpa. Efectivamente coincido contigo.

Otra cosa que también he experimentado alguna vez con el CPC en concreto, es que las secciones de los cables son importantes de verdad, o sea, que secciones de cable pequeñas en los cables de los conectores pueden hacer que el CPC se reinicie o se cuelgue. Me pasó precisamente cuando monté una fuente genérica como se comenta en este hilo, usando una "pico PSU" (sin ventiladores ni nada), y el cable para el CPC que hice tenía varios jacks de alimentación en paralelo para alimentar también las otras placas y/o periféricos; de modo que para que los jacks de alimentación tuviesen cable de entrada y de salida para el siguiente jack, y cupieran los cuatro cables, utilicé una sección que pensé que no era escasa, pero resultó que sí, y tardé días en descubrir que aquellos cuelgues extraños eran por el cable. No pienso que este sea el problema que se plantea aquí porque este CPC en cuestión ni siquiera está arrancando, pero lo comento porque me lo ha recordado.

Re: CPC 464 recién comprado. Duda transformador

Publicado: 01 Jun 2018, 10:56
por GUSS
Buenas.

Gracias por las ideas. He estado probando lo que comentáis del tamaño del conector y lo que he hecho es moverlo un poco para intentar que tanto la aguja de dentro como la parte de fuera hiciesen contacto, pero nada.

He vuelto a conectar el transformador y noto que cuando le doy al interruptor de encendido del CPC tarda como unos 2 segundos en arrancar (el 6128 lo hace instantáneo). He continuado haciendo más pruebas y ahora ya no enciende con ningún transformador.

Creo que es posible que la placa de alimentación no esté bien, he abierto el CPC, pero no me ha dado tiempo a mucho más. Veo que hay unos cables que salen por debajo del cassette y alimentan la placa del ordenador. Creo que el problema estará por ahí. Empezaré midiendo las tensiones de esos cables para ver qué le llega a la placa. ¿Podríais indicarme el esquema de ese conector y qué valores tienen los diferentes cables para poder realizar la medición?

Si de os ocurre alguna otra cosa que sepáis que le puede pasar os lo agradecería.

Un saludo

Re: CPC 464 recién comprado. Duda transformador

Publicado: 01 Jun 2018, 12:05
por duca750
También es posible que tengas que resoldar el conector de corriente a la placa de nuevo, dudo que sea por el conector del Cassette, pero revisa también las soldaduras y echa líquido de limpieza de contactos en el interruptor también. Verifica a continuidad, a veces a simple vista parece estar bien, pero la pista puede estar cortada.