Spectrum +3 con caracteres raros en pantalla

Moderador: Fundadores

Responder
Avatar de Usuario
duca750
Demonio tercer orden
Demonio tercer orden
Mensajes: 834
Registrado: 28 Ago 2017, 13:14
Contactar:

Spectrum +3 con caracteres raros en pantalla

Mensaje por duca750 » 09 Jun 2018, 13:15

Pues eso, estoy probando uno de mis Spectrum +3, y lo veo con caracteres raros en pantalla, salen unas veces unos y otras otros, incluso alguna vez pantalla multicolor y pone muchas veces 1987, alguna idea? A veces se queda borde blanco y fondo negro, como digo no hay patron.
IMG_20180609_125703-1152x864.jpg
IMG_20180609_125703-1152x864.jpg (142.1 KiB) Visto 133 veces
IMG_20180609_130233-1152x864.jpg
IMG_20180609_130233-1152x864.jpg (153.92 KiB) Visto 133 veces
Paso imagenes y incluyo lo que sale tambien con el dandanator:
IMG_20180609_130136-1152x864.jpg
IMG_20180609_130136-1152x864.jpg (157.79 KiB) Visto 133 veces
Última edición por duca750 el 09 Jun 2018, 13:18, editado 1 vez en total.
Mi coleccion: CPC464,CPC6128/GX4000/COMMODORE 64,AMIGA 500/ATARI STFM1024/ORIC1,ATMOS/DRAGON32/SPECTRUM+, +2,+3,48K,16K/MSX HB501P,101P,201P,MSX HB20P,HB75P,CANON V20,PHILIPS MSX2 NMS8250,8020/TOSHIBA MSX/ACORN ELECTRON/THOMSON MO08,MO05,ENTERPRISE 64.

Avatar de Usuario
duca750
Demonio tercer orden
Demonio tercer orden
Mensajes: 834
Registrado: 28 Ago 2017, 13:14
Contactar:

Re: Spectrum +3 con caracteres raros en pantalla

Mensaje por duca750 » 09 Jun 2018, 13:17

Paso otra imagen:
IMG_20180609_130429-1152x864.jpg
IMG_20180609_130429-1152x864.jpg (201.28 KiB) Visto 130 veces
Mi coleccion: CPC464,CPC6128/GX4000/COMMODORE 64,AMIGA 500/ATARI STFM1024/ORIC1,ATMOS/DRAGON32/SPECTRUM+, +2,+3,48K,16K/MSX HB501P,101P,201P,MSX HB20P,HB75P,CANON V20,PHILIPS MSX2 NMS8250,8020/TOSHIBA MSX/ACORN ELECTRON/THOMSON MO08,MO05,ENTERPRISE 64.

Avatar de Usuario
javier2112
Aspirante a demonio
Aspirante a demonio
Mensajes: 421
Registrado: 30 Oct 2014, 12:36
Ubicación: Málaga
Contactar:

Re: Spectrum +3 con caracteres raros en pantalla

Mensaje por javier2112 » 09 Jun 2018, 13:34

¿Tienes varios +3 y no sabes lo que es lo de la primera foto? Parece que esos ordenadores no los has conocido hasta hace más bien poco tiempo :D es la carta de ajuste que aparece cuando durante el encendido dejas pulsada la tecla break. Puede que esa tecla la tengas bloqueada.

Sí otras veces te aparecen esas otras pantallas que pones, es posible que tengas mal alguna memoria RAM, también podría ser la rom o incluso la CPU. Lo más rápido es empezar por comprobar estas últimas puesto que van en zócalo.

Saludos.

Avatar de Usuario
flopping
Fundador
Fundador
Mensajes: 8050
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Contactar:

Re: Spectrum +3 con caracteres raros en pantalla

Mensaje por flopping » 09 Jun 2018, 14:01

La ultima imagen es curiosa, ya que el borde está en dos colores, o sea que o está mal la ULA o las memorias ram, la cpu se ve bien, para evitar problemas con el teclado desconéctalo a ver si deja de hacerte cosas raras, sobre todo no debería de salir la pantalla de las barras de color, si sigue saliendo es que la ULA está mal.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2018, 36 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
duca750
Demonio tercer orden
Demonio tercer orden
Mensajes: 834
Registrado: 28 Ago 2017, 13:14
Contactar:

Re: Spectrum +3 con caracteres raros en pantalla

Mensaje por duca750 » 09 Jun 2018, 14:21

flopping escribió:
09 Jun 2018, 14:01
La ultima imagen es curiosa, ya que el borde está en dos colores, o sea que o está mal la ULA o las memorias ram, la cpu se ve bien, para evitar problemas con el teclado desconéctalo a ver si deja de hacerte cosas raras, sobre todo no debería de salir la pantalla de las barras de color, si sigue saliendo es que la ULA está mal.
Descartada ROM y CPU, las memorias están en zocalo con lo que ya se debe haber reparado anteriormente, he limpiado contactos y sigue igual, no responde a dandanator tampoco, sabéis que memorias debo utilizar? Pregunto porque estoy acostumbrado al chorro de modulos de amstrad, pero en este solo hay 4 modulos.
Mi coleccion: CPC464,CPC6128/GX4000/COMMODORE 64,AMIGA 500/ATARI STFM1024/ORIC1,ATMOS/DRAGON32/SPECTRUM+, +2,+3,48K,16K/MSX HB501P,101P,201P,MSX HB20P,HB75P,CANON V20,PHILIPS MSX2 NMS8250,8020/TOSHIBA MSX/ACORN ELECTRON/THOMSON MO08,MO05,ENTERPRISE 64.

Avatar de Usuario
duca750
Demonio tercer orden
Demonio tercer orden
Mensajes: 834
Registrado: 28 Ago 2017, 13:14
Contactar:

Re: Spectrum +3 con caracteres raros en pantalla

Mensaje por duca750 » 09 Jun 2018, 14:24

flopping escribió:
09 Jun 2018, 14:01
La ultima imagen es curiosa, ya que el borde está en dos colores, o sea que o está mal la ULA o las memorias ram, la cpu se ve bien, para evitar problemas con el teclado desconéctalo a ver si deja de hacerte cosas raras, sobre todo no debería de salir la pantalla de las barras de color, si sigue saliendo es que la ULA está mal.
Hay una memoria 4464 que se pone a tope de calor
Mi coleccion: CPC464,CPC6128/GX4000/COMMODORE 64,AMIGA 500/ATARI STFM1024/ORIC1,ATMOS/DRAGON32/SPECTRUM+, +2,+3,48K,16K/MSX HB501P,101P,201P,MSX HB20P,HB75P,CANON V20,PHILIPS MSX2 NMS8250,8020/TOSHIBA MSX/ACORN ELECTRON/THOMSON MO08,MO05,ENTERPRISE 64.

Avatar de Usuario
flopping
Fundador
Fundador
Mensajes: 8050
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Contactar:

Re: Spectrum +3 con caracteres raros en pantalla

Mensaje por flopping » 09 Jun 2018, 15:39

duca750 escribió:
09 Jun 2018, 14:24
flopping escribió:
09 Jun 2018, 14:01
La ultima imagen es curiosa, ya que el borde está en dos colores, o sea que o está mal la ULA o las memorias ram, la cpu se ve bien, para evitar problemas con el teclado desconéctalo a ver si deja de hacerte cosas raras, sobre todo no debería de salir la pantalla de las barras de color, si sigue saliendo es que la ULA está mal.
Hay una memoria 4464 que se pone a tope de calor
Pues ya tienes un candidato a cambiar, puedes intercambiar esa memoria con las otras y ver qué efecto hace, por si cambiará en algo, una prueba que puedes hacer es quitar las dos memorias superiores y dejar las dos inferiores y poner una rom de 48k, de esta forma lo estamos donwgradeando a un 48k,así podrías ver si el equipo funciona bien, me refiero a la ULA y así seguro que podríamos afirmar que está mal la memoria, creo que habría que hacer un puente en el zócalo que se queda libre de la rom, ya que estos equipos tienen 2 roms y 4 bancos, mientas que el 48k solo tiene 1 y 1.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2018, 36 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
duca750
Demonio tercer orden
Demonio tercer orden
Mensajes: 834
Registrado: 28 Ago 2017, 13:14
Contactar:

Re: Spectrum +3 con caracteres raros en pantalla

Mensaje por duca750 » 09 Jun 2018, 16:24

flopping escribió:
09 Jun 2018, 15:39
duca750 escribió:
09 Jun 2018, 14:24
flopping escribió:
09 Jun 2018, 14:01
La ultima imagen es curiosa, ya que el borde está en dos colores, o sea que o está mal la ULA o las memorias ram, la cpu se ve bien, para evitar problemas con el teclado desconéctalo a ver si deja de hacerte cosas raras, sobre todo no debería de salir la pantalla de las barras de color, si sigue saliendo es que la ULA está mal.
Hay una memoria 4464 que se pone a tope de calor
Pues ya tienes un candidato a cambiar, puedes intercambiar esa memoria con las otras y ver qué efecto hace, por si cambiará en algo, una prueba que puedes hacer es quitar las dos memorias superiores y dejar las dos inferiores y poner una rom de 48k, de esta forma lo estamos donwgradeando a un 48k,así podrías ver si el equipo funciona bien, me refiero a la ULA y así seguro que podríamos afirmar que está mal la memoria, creo que habría que hacer un puente en el zócalo que se queda libre de la rom, ya que estos equipos tienen 2 roms y 4 bancos, mientas que el 48k solo tiene 1 y 1.
Gracias, he comprobado que tengo dos modulos nuevos de 4464 en mis repuestos, los he probado y no mejora la cosa, a veces inicia parpadeando el borde blanco y fondo negro varias veces y a veces y otras veces, salen esos colores raros.

Seguramente es una burrada porque no coincidan los patillajes, pero aunque tuviera menos memoria, podria poner 4164 que si tengo varias unidades? Gracias.
Mi coleccion: CPC464,CPC6128/GX4000/COMMODORE 64,AMIGA 500/ATARI STFM1024/ORIC1,ATMOS/DRAGON32/SPECTRUM+, +2,+3,48K,16K/MSX HB501P,101P,201P,MSX HB20P,HB75P,CANON V20,PHILIPS MSX2 NMS8250,8020/TOSHIBA MSX/ACORN ELECTRON/THOMSON MO08,MO05,ENTERPRISE 64.

Avatar de Usuario
Kyp
Demonio segundo orden
Demonio segundo orden
Mensajes: 1935
Registrado: 30 Sep 2013, 14:54
Ubicación: Madrid
Contactar:

Re: Spectrum +3 con caracteres raros en pantalla

Mensaje por Kyp » 09 Jun 2018, 17:58

Haz como dice flopping. Deja solo los chips de RAM IC3 e IC4, y pon una EPROM de 32K con la ROM del Spectrum 48K repetida para llenar los 32K en IC7. Es algo que no he probado nunca, pero en teoría debería funcionar como un Spectrum de 48K. De todas formas, eso de que salga media pantalla de un color y media de otro tiene mala pinta.

Responder

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado