Página 1 de 5

Pantalla cuadritos colores gomas 48k (Casi solucionado)

Publicado: 02 Jun 2020, 20:16
por duca750
Buenas tardes compañeros, tras cambiar tr4 y tr5 además de quitar toda la RAM baja (4116) he recuperado todos los voltajes correctamente, antes de poner las 4164 modificadas he probado con el módulo LO RAM de kyp, el tema es que obtengo una pantalla con fondo gris llena de cuadros de colores que no paran de cambiar de color. Alguna idea de que más mirar?

Tengo Dandanator pero no accede a la ROM test, el módulo LO RAM no lo he probado antes, pero imagino que está perfecto.

Adjunto vídeo foto no me deja.



El equipo tras cambiar Z80 ya arranca perfectamente, lo que tienen son muchas interferencias en pantalla, pese a haber cambiado la las memorias, Z80, condensadores, TR4, TR5, LM1889.

Re: Pantalla cuadritos colores gomas 48k

Publicado: 02 Jun 2020, 21:16
por Kyp
La ROM de test debería funcionar aunque no haya memoria baja, no se vería nada pero cambiaría el borde. Si no arranca el test mi siguiente sospechoso sería la CPU.

Re: Pantalla cuadritos colores gomas 48k

Publicado: 02 Jun 2020, 22:06
por Popopo
duca750 escribió:
02 Jun 2020, 20:16
Buenas tardes compañeros, tras cambiar tr4 y tr5 además de quitar toda la RAM baja (4116) he recuperado todos los voltajes correctamente, antes de poner las 4164 modificadas he probado con el módulo LO RAM de kyp, el tema es que obtengo una pantalla con fondo gris llena de cuadros de colores que no paran de cambiar de color. Alguna idea de que más mirar?

Tengo Dandanator pero no accede a la ROM test, el módulo LO RAM no lo he probado antes, pero imagino que está perfecto.

Adjunto vídeo foto no me deja.

Edito:

Los módulos igual no están haciendo buena inserción. Pueden ser muchas cosas, en mi caso primeramente eran módulos ram fastidiados (aparte del chamuscado TR4) aun con todo me salía esa pantalla... puedes puentear la RAM alta para ignorarla. el Dandanator ¿no lo conectas al SLot de expansión del Spectrum?

La RAM baja deberá ser mirada, si usas el módulo Kyp asegúrate que los zócalos no te hacen mala jugada dejando algún pin al aire de alguno de los lados.
Ya por último sería mirar la ULA... o ... los chips multiplexores.
Qué Issue es? Por lo que parece... debe ser una Issue4 o superior...
olvidate de TR4 y TR5, si fuera TR4 verías en blanco y negro la pantalla

Re: Pantalla cuadritos colores gomas 48k

Publicado: 02 Jun 2020, 22:41
por duca750
Kyp escribió:
02 Jun 2020, 21:16
La ROM de test debería funcionar aunque no haya memoria baja, no se vería nada pero cambiaría el borde. Si no arranca el test mi siguiente sospechoso sería la CPU.
Subí vídeo sin Dandanator, el patrón cambia según los encendidos. Todas las pruebas son sin RAM.

Después pongo el Dandanator y la última prueba con el botón pulsado para que inicie la ROM test.



Popopo escribió:
02 Jun 2020, 22:06
duca750 escribió:
02 Jun 2020, 20:16
Buenas tardes compañeros, tras cambiar tr4 y tr5 además de quitar toda la RAM baja (4116) he recuperado todos los voltajes correctamente, antes de poner las 4164 modificadas he probado con el módulo LO RAM de kyp, el tema es que obtengo una pantalla con fondo gris llena de cuadros de colores que no paran de cambiar de color. Alguna idea de que más mirar?

Tengo Dandanator pero no accede a la ROM test, el módulo LO RAM no lo he probado antes, pero imagino que está perfecto.

Adjunto vídeo foto no me deja.

Edito:

Los módulos igual no están haciendo buena inserción. Pueden ser muchas cosas, en mi caso primeramente eran módulos ram fastidiados (aparte del chamuscado TR4) aun con todo me salía esa pantalla... puedes puentear la RAM alta para ignorarla. el Dandanator ¿no lo conectas al SLot de expansión del Spectrum?

La RAM baja deberá ser mirada, si usas el módulo Kyp asegúrate que los zócalos no te hacen mala jugada dejando algún pin al aire de alguno de los lados.
Ya por último sería mirar la ULA... o ... los chips multiplexores.
Qué Issue es? Por lo que parece... debe ser una Issue4 o superior...
olvidate de TR4 y TR5, si fuera TR4 verías en blanco y negro la pantalla
Es una issue 6A, el módulo encaja perfectamente.

Re: Pantalla cuadritos colores gomas 48k

Publicado: 03 Jun 2020, 00:51
por duca750
Bueno cambiando Z80, ya tengo un RAM fail 4 con el módulo LO RAM, aunque se ve mal, vamos avanzando. Este error se referirá a la memoria alta? Cuál es el 4?


Re: Pantalla cuadritos colores gomas 48k

Publicado: 03 Jun 2020, 09:25
por Kyp
No, se refiere a la RAM baja. Revisa que haga buen contacto el módulo o que no se haya levantado alguna pista al quitar los chips. Ya no me acuerdo si van de derecha a izquierda o al revés, pero el cuarto sería uno de los dos del centro.

Re: Pantalla cuadritos colores gomas 48k

Publicado: 03 Jun 2020, 11:56
por Popopo
duca750 escribió:
03 Jun 2020, 00:51
Bueno cambiando Z80, ya tengo un RAM fail 4 con el módulo LO RAM, aunque se ve mal, vamos avanzando. Este error se referirá a la memoria alta? Cuál es el 4?

ULA, aparte de algún módulo RAM extra... o un multiplezor... ULA, prueba por favor a intercambiar la ULA con alguno que te funcione bien. Justo tienes el mismo patrón ahora que la placa que acabo de reparar, después de cambiar la memoria alta y baja, pudo ser algún multiplexor de los SN74xx175, pero en mi caso ... ULA.

Re: Pantalla cuadritos colores gomas 48k

Publicado: 03 Jun 2020, 11:59
por Popopo
duca750 escribió:
03 Jun 2020, 00:51
Bueno cambiando Z80, ya tengo un RAM fail 4 con el módulo LO RAM, aunque se ve mal, vamos avanzando. Este error se referirá a la memoria alta? Cuál es el 4?

Bueno, en este vídeo se te ve mucho mejor que a mi. ENtonces viendo esto... ya no sabría que decirte. Como la pantalla que mostrabas después, era en mi caso la ULA y dos chips ram churruscados.

Y sigue pareciendo que uno de los bits está fallando, de los chips de memoria. Que interesante. Como no tienes multiplexores... puede ser desde el PCF o ULA (si estás seguro que las RAM están OK),

Re: Pantalla cuadritos colores gomas 48k

Publicado: 03 Jun 2020, 12:25
por Kyp
Podría ser el PCF pero la ULA no. Si fallara la ULA se vería mal pero pasaría el test. Si el test falla es porque la CPU escribe una cosa y lee otra. Ni influye si se ve bien o mal.

Re: Pantalla cuadritos colores gomas 48k

Publicado: 03 Jun 2020, 16:11
por Popopo
Kyp escribió:
03 Jun 2020, 12:25
Podría ser el PCF pero la ULA no. Si fallara la ULA se vería mal pero pasaría el test. Si el test falla es porque la CPU escribe una cosa y lee otra. Ni influye si se ve bien o mal.
En la Issue 3, que he arreglado, me pasaba el test, pero era casi ilegible... creo que conservo alguna foto todavía.. Seguramente no sea la ULA... pero a mi me daba estos problemas:



Imagen
Imagen

edito: Entiendo lo que quieres decir Kyp, yo me centraba en la imagen, pero tu centras en un problema que está antes. Entiendo. PCF o ... ROM no creo, Z80... son duros... no sé. Siento no poder aportar más.