Problema con conector edge en Spectrum 48k ¡¡EN PAUSA¡¡

¿Tienes problemas con tu equipo?, preguntanos.

Moderador: Fundadores

Avatar de Usuario
flopping
Fundador
Fundador
Mensajes: 9897
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Been thanked: 62 times
Contactar:

Re: Problema con conector edge en Spectrum 48k

Mensaje por flopping »

Una cosa, si le has puesto estaño a los contactos del conector trasero, espero que le hallas pasado malla de desoldar y que esten todos los contactos limpios, el aportar estaño al conector, no es una bunea idea, a no ser que como te digo,luego le hallas quitado todo el estaño, ya que si no, se crean irregularidades y se deforman los conectores que les conectes a ese spectrum.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide.
(C) 1982-2023, 41 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Mi juego, que puedes descargarlo de aqui
Avatar de Usuario
cacharreo !Sinclair 1
Moderador
Moderador
Mensajes: 2796
Registrado: 09 Ago 2019, 10:17
Ubicación: /home/cacharreo/
Has thanked: 636 times
Been thanked: 1111 times
Contactar:

Re: Problema con conector edge en Spectrum 48k

Mensaje por cacharreo »

Muy cierto, añadir estaño de esa manera sin poder hacer un baño en condiciones como en las fábricas es muy delicado porque va a quedar irregular sí o sí (excepto con la malla o una desoldadora con bomba decente), por eso que preferiría haber limpiado/pulido bien desde el principio.
© cacharreo
Avatar de Usuario
andorra04 Andorra
El infierno es su lugar
El infierno es su lugar
Mensajes: 140
Registrado: 22 Dic 2022, 19:31
Has thanked: 145 times
Been thanked: 36 times

Re: Problema con conector edge en Spectrum 48k

Mensaje por andorra04 »

ahi teneis razon. no le pase la malla limpie con un cepillo y alcohol y luego repase los contactos con estaño.
cuando hice eso el problema ya existia, era un intento de solucionarlo pero no ha ido ni a mejor ni a peor
de todas formas comprare malla y limpiare el estaño de mas

gracias
Avatar de Usuario
flopping
Fundador
Fundador
Mensajes: 9897
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Been thanked: 62 times
Contactar:

Re: Problema con conector edge en Spectrum 48k

Mensaje por flopping »

Ok, pues entonces por lo que comentas, quiza deberias de revisar TR6 o sus contactos, es el transistor que esta encima del Z80, mira que sus conexiones esten bien y si lo estan, cambialo por otro igual o un equivalente, no es Transistor muy critico, por lo que probablemente un BC xxx te servira, busca equivalencias.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide.
(C) 1982-2023, 41 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Mi juego, que puedes descargarlo de aqui
Avatar de Usuario
andorra04 Andorra
El infierno es su lugar
El infierno es su lugar
Mensajes: 140
Registrado: 22 Dic 2022, 19:31
Has thanked: 145 times
Been thanked: 36 times

Re: Problema con conector edge en Spectrum 48k

Mensaje por andorra04 »

flopping escribió: 26 Dic 2022, 20:12 Ok, pues entonces por lo que comentas, quiza deberias de revisar TR6 o sus contactos, es el transistor que esta encima del Z80, mira que sus conexiones esten bien y si lo estan, cambialo por otro igual o un equivalente, no es Transistor muy critico, por lo que probablemente un BC xxx te servira, busca equivalencias.
te refieres a este que he marcado en amarillo??
IMG_6291a.jpg
gracias
No tiene los permisos requeridos para ver los archivos adjuntos a este mensaje.
Avatar de Usuario
andorra04 Andorra
El infierno es su lugar
El infierno es su lugar
Mensajes: 140
Registrado: 22 Dic 2022, 19:31
Has thanked: 145 times
Been thanked: 36 times

Re: Problema con conector edge en Spectrum 48k

Mensaje por andorra04 »

hola el transistor es este
IMG_6292.JPG
alguien sabe la equivalencia.
Es que aqui donde puedo ir a comprar estos componentes si no les llevas todos los datos no te ayudan lo mas minimo
yo he encontrado uno que es el BC547 pero si alguien me confirma ese o me dice otro perfecto

gracias
No tiene los permisos requeridos para ver los archivos adjuntos a este mensaje.
Avatar de Usuario
cacharreo !Sinclair 1
Moderador
Moderador
Mensajes: 2796
Registrado: 09 Ago 2019, 10:17
Ubicación: /home/cacharreo/
Has thanked: 636 times
Been thanked: 1111 times
Contactar:

Re: Problema con conector edge en Spectrum 48k

Mensaje por cacharreo »

Si lo necesitaras puedes comprar el ZTX313 en AliExpress.

A propósito si ese transistor no fuera bien, fallaría el test de bus flotante por lo que se puede comprobar por software.
© cacharreo
Avatar de Usuario
Kyp !Sinclair 1
Hermano de Lucifer
Hermano de Lucifer
Mensajes: 3267
Registrado: 30 Sep 2013, 14:54
Ubicación: Madrid
Has thanked: 10 times
Been thanked: 76 times

Re: Problema con conector edge en Spectrum 48k

Mensaje por Kyp »

Te vale el BC547 pero comprueba la orientación que creo que va a l revés.
Avatar de Usuario
cacharreo !Sinclair 1
Moderador
Moderador
Mensajes: 2796
Registrado: 09 Ago 2019, 10:17
Ubicación: /home/cacharreo/
Has thanked: 636 times
Been thanked: 1111 times
Contactar:

Re: Problema con conector edge en Spectrum 48k

Mensaje por cacharreo »

Efectivamente tienen los pines invertidos. Mirándolos como si estuvieran tumbados con la cara plana hacia arriba, el ZTX313 es EBC mientras que el BC547 es CBE.
© cacharreo
Avatar de Usuario
flopping
Fundador
Fundador
Mensajes: 9897
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Been thanked: 62 times
Contactar:

Re: Problema con conector edge en Spectrum 48k

Mensaje por flopping »

Te he comentado que revises el transistor, por que dices que te falla incluso un interface de joystick kempston y justamente esos interfaces de joystick, son muy simples y usan muy pocas señales, generalmente, algunosbits de datos, RD e IORQ y esta ultima es la que genera ese transistor, pero tambien podria ser que tuvieras un microcorte en esa pista o en varias,si puedes mide con un polimetro en elborde del conector entre ese contacto y el pin donde va conectado al transistor, por si estuviera cortado y si puedes medir el transistor o directamente cambiarlo para probar a ver si notas algun cambio.

Otra posibilidad es que fallase la ULA, pero lo veo poco probable, aunque si puedes probarla en otro equipo o poner otra ULA, asi salimos de dudas sobre si esta mal.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide.
(C) 1982-2023, 41 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Mi juego, que puedes descargarlo de aqui
Responder

Volver a “Consultas”