Fallo color ZX Spectrum 48k+ issue 3b

¿Tienes problemas con tu equipo?, preguntanos.

Moderador: Fundadores

eljubizx
Seguidor infernal
Seguidor infernal
Mensajes: 21
Registrado: 03 Nov 2020, 13:02
Been thanked: 2 times

Fallo color ZX Spectrum 48k+ issue 3b

Mensaje por eljubizx »

Tengo un Zx 48 k plus ,al conectarlo aparece el mensaje de sinclair cambio el color del borde y se queda en blanco y negro he comprobado la tensión del tm y es correcta da 12 v ,las tensiones de las memorias son correctas también tiene otro problema curioso al teclear una línea de basic he intentar subirla a la parte superior de la pantalla se bloquea y aparecen en pantalla símbolos raros donde debería estar la línea de basic y a veces hace reset.Al poner por ejemplo el comando print "hola" no lo ejecuta aunque le des a la tecla intro, se bloquea.He puesto el dandanator + multiply y aunque no me funciona si aparece color en la pantalla, este dandanator no funciona en otro spectrum que está bien.
ehontecillas
Aspirante a demonio
Aspirante a demonio
Mensajes: 344
Registrado: 29 Abr 2013, 23:08
Has thanked: 6 times
Been thanked: 46 times

Re: Fallo color Zx issue 3b

Mensaje por ehontecillas »

Cambia los condensadores que están abajo, los de 100 uF, Si están mal, no filtran las tensiones de 12 y -12 y puede dar fallos la memoria baja y el LM.
Avatar de Usuario
flopping
Fundador
Fundador
Mensajes: 9898
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Been thanked: 62 times
Contactar:

Re: Fallo color Zx issue 3b

Mensaje por flopping »

Tiene pinta de que tengas alguna memoria “pocha”, pásale un test a ver.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide.
(C) 1982-2023, 41 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Mi juego, que puedes descargarlo de aqui
Avatar de Usuario
mad3001 !Atari
Demonio segundo orden
Demonio segundo orden
Mensajes: 1699
Registrado: 25 Nov 2015, 00:15
Ubicación: Mostoles(Madrid)
Has thanked: 25 times
Been thanked: 44 times

Re: Fallo color Zx issue 3b

Mensaje por mad3001 »

eljubizx escribió: 20 Ene 2023, 16:49 Tengo un Zx 48 k plus ,al conectarlo aparece el mensaje de sinclair cambio el color del borde y se queda en blanco y negro he comprobado la tensión del tm y es correcta da 12 v ,las tensiones de las memorias son correctas también tiene otro problema curioso al teclear una línea de basic he intentar subirla a la parte superior de la pantalla se bloquea y aparecen en pantalla símbolos raros donde debería estar la línea de basic y a veces hace reset.Al poner por ejemplo el comando print "hola" no lo ejecuta aunque le des a la tecla intro, se bloquea.He puesto el dandanator + multiply y aunque no me funciona si aparece color en la pantalla, este dandanator no funciona en otro spectrum que está bien.
A ver el 48+ está pocho y ¿el dandanator + multiply tambien? ¿Es eso o se coló un NO en "este dandanator no funciona en otro spectrum que está bien" ?
Volviendo a los origenes... programa en assembler
eljubizx
Seguidor infernal
Seguidor infernal
Mensajes: 21
Registrado: 03 Nov 2020, 13:02
Been thanked: 2 times

Re: Fallo color Zx issue 3b

Mensaje por eljubizx »

El dandanator no funciona en un spectrum que está bien salen las rayas verticales azul y negro y si pulso el botón izquierdo del dandanator al arrancar el spectrum sale el borde con rayas finas de colores y en la pantalla con cuadros de colores y un ruido en el altavoz. Probaré a cambiar los condensadores de 100 uf del zx a ver qué pasa.
Avatar de Usuario
duca750 España - Extremadura
Hermano de Lucifer
Hermano de Lucifer
Mensajes: 2264
Registrado: 28 Ago 2017, 13:14
Has thanked: 144 times
Been thanked: 117 times

Re: Fallo color Zx issue 3b

Mensaje por duca750 »

eljubizx escribió: 22 Ene 2023, 14:28 El dandanator no funciona en un spectrum que está bien salen las rayas verticales azul y negro y si pulso el botón izquierdo del dandanator al arrancar el spectrum sale el borde con rayas finas de colores y en la pantalla con cuadros de colores y un ruido en el altavoz. Probaré a cambiar los condensadores de 100 uf del zx a ver qué pasa.
Deberías revisar también el dandanator, a parte de los condensadores que nunca está de más revisarlos y cambiarlos, probablemente tengas mal el TEA2000.
Mi coleccion: CPC464,CPC6128/GX4000/COMMODORE 64,AMIGA 500/ATARI STFM1024/ORIC1,ATMOS/DRAGON32/SPECTRUM+, +2,+3,48K,16K/MSX HB501P,101P,201P,MSX HB20P,HB75P,CANON V20,PHILIPS MSX2 NMS8250,8020/TOSHIBA MSX/ACORN ELECTRON/THOMSON MO08,MO05,ENTERPRISE 64.
eljubizx
Seguidor infernal
Seguidor infernal
Mensajes: 21
Registrado: 03 Nov 2020, 13:02
Been thanked: 2 times

Re: Fallo color Zx issue 3b

Mensaje por eljubizx »

Esta imagen sale al poner el dandanator y arrancar con el botón izquierdo apretado si después pulso el derecho hace reset.
No tiene los permisos requeridos para ver los archivos adjuntos a este mensaje.
Avatar de Usuario
cacharreo !Sinclair 1
Moderador
Moderador
Mensajes: 2840
Registrado: 09 Ago 2019, 10:17
Ubicación: /home/cacharreo/
Has thanked: 646 times
Been thanked: 1152 times
Contactar:

Re: Fallo color Zx issue 3b

Mensaje por cacharreo »

Y entendermos que el "spectrum que está bien" sin DD! arranca sin problemas, ¿correcto?
© cacharreo
Avatar de Usuario
JupiterJones España - Cataluña
Demonio tercer orden
Demonio tercer orden
Mensajes: 573
Registrado: 06 Feb 2020, 01:16
Ubicación: Barcelona
Has thanked: 169 times
Been thanked: 94 times

Re: Fallo color Zx issue 3b

Mensaje por JupiterJones »

Borde amarillo... La CPU no arranca. El Borde debería ser gris claro si el Z80 arranca. Si sólo pasa con el DD conectado prueba asentar el DD, limpia bien los contactos que no tengas porquería haciendo un corto y te ponga la linea de RESET a 0... Eso asumiendo lo que te pregunta @cacharreo.
eljubizx
Seguidor infernal
Seguidor infernal
Mensajes: 21
Registrado: 03 Nov 2020, 13:02
Been thanked: 2 times

Re: Fallo color Zx issue 3b

Mensaje por eljubizx »

El spectrum sin dd arranca perfectamente
Responder

Volver a “Consultas”