Página 2 de 3

Re: Problema raro con algunos juegos en CPC464

Publicado: 04 Feb 2019, 21:24
por catenaccio
overCLK escribió:
04 Feb 2019, 19:27
Pues eso sí que me descoloca bastante, pero bueno, te explico mi teoría:

El Return of Traxtor tiene una rutina de lectura de teclado que también modifica el estado del motor del CPC. Esto se debe a que el byte donde se configura el estado del motor es el mismo que controla qué fila del teclado se lee (utilizando diferentes bits) pero los valores que utiliza el juego para ese byte modifican también el estado del motor.

Por lo que parece, este detalle pasa desapercibido para un CPC "normal", podría ser porque estos cambios rápidos de estado son absorbidos por la circuitería relacionada. Pero de todos modos, el juego está provocando cambios rápidos del estado del relé, o al menos intentándolo, cosa que no parece muy correcta.

La versión que puse aquí cambia los rangos de ese byte de control para que no se modifique el estado del motor durante la lectura de teclado. Lo he probado con un emulador y he visto que en efecto ya no se hacen esos cambios de estado y estaba convencido de que con este SNA se eliminarían esos efectos extraños con el relé.

Lo único que puedo decirte es que te asegures de que has probado exactamente esta versión que he puesto. ¿Cómo ha hecho la actualización? Si puedes pásame el romset que has generado con este juego para confirmar que todo está como debe ahí.
Aquí te dejo el romset creado:
dandanator_2.0modif.rar
romset
dandanator_2.0modif.rar (314.62 KiB) Visto 50 veces
El hecho es que incluso redefiniendo las teclas, se ve que está activo el motor del relé, ya que vibra. Y en el momento de jugar es cuando se vuelve loco.

Lo que mas me desconcierta a mi, es que antes de tener que sustituir el z80 me funcionaban estos juegos que ahora fallan (Operacion Alexandra, por ejemplo)

No sé si el chip AY de sonido o algún condensador pueden estar dañados, pero lo que está claro es que hay algo más roto en este CPC464.

Re: Problema raro con algunos juegos en CPC464

Publicado: 04 Feb 2019, 22:25
por Spirax
catenaccio escribió:
04 Feb 2019, 21:24
Lo que mas me desconcierta a mi, es que antes de tener que sustituir el z80 me funcionaban estos juegos que ahora fallan (Operacion Alexandra, por ejemplo)
pregunta de ignorante del CPC. que tipo de z80 le has puesto? exactamente igual que el que tenia original o de o puede ser uno de los nuevos
¿pueden ir por ahi los tiros y que se comporte diferente el nuevo Z80?

Re: Problema raro con algunos juegos en CPC464

Publicado: 04 Feb 2019, 22:34
por overCLK
catenaccio escribió:
04 Feb 2019, 21:24
overCLK escribió:
04 Feb 2019, 19:27
Pues eso sí que me descoloca bastante, pero bueno, te explico mi teoría:

El Return of Traxtor tiene una rutina de lectura de teclado que también modifica el estado del motor del CPC. Esto se debe a que el byte donde se configura el estado del motor es el mismo que controla qué fila del teclado se lee (utilizando diferentes bits) pero los valores que utiliza el juego para ese byte modifican también el estado del motor.

Por lo que parece, este detalle pasa desapercibido para un CPC "normal", podría ser porque estos cambios rápidos de estado son absorbidos por la circuitería relacionada. Pero de todos modos, el juego está provocando cambios rápidos del estado del relé, o al menos intentándolo, cosa que no parece muy correcta.

La versión que puse aquí cambia los rangos de ese byte de control para que no se modifique el estado del motor durante la lectura de teclado. Lo he probado con un emulador y he visto que en efecto ya no se hacen esos cambios de estado y estaba convencido de que con este SNA se eliminarían esos efectos extraños con el relé.

Lo único que puedo decirte es que te asegures de que has probado exactamente esta versión que he puesto. ¿Cómo ha hecho la actualización? Si puedes pásame el romset que has generado con este juego para confirmar que todo está como debe ahí.
Aquí te dejo el romset creado:

dandanator_2.0modif.rar

El hecho es que incluso redefiniendo las teclas, se ve que está activo el motor del relé, ya que vibra. Y en el momento de jugar es cuando se vuelve loco.

Lo que mas me desconcierta a mi, es que antes de tener que sustituir el z80 me funcionaban estos juegos que ahora fallan (Operacion Alexandra, por ejemplo)

No sé si el chip AY de sonido o algún condensador pueden estar dañados, pero lo que está claro es que hay algo más roto en este CPC464.
Pues si ese es el romset que has grabado en el dandanator y el juego que has probado, ya no sé a que se puede deber que en esos juegos te hagan ese zumbido del relé. Con la versión de la web tiene una explicación, pero con esta... no sé.

Re: Problema raro con algunos juegos en CPC464

Publicado: 04 Feb 2019, 22:36
por catenaccio
Spirax escribió:
04 Feb 2019, 22:25
pregunta de ignorante del CPC. que tipo de z80 le has puesto? exactamente igual que el que tenia original o de o puede ser uno de los nuevos
¿pueden ir por ahi los tiros y que se comporte diferente el nuevo Z80?
Hola Spirax, pues aquí mismo te dejo el modelo que llevaba (arriba) y el que está puesto ahora mismo en placa (abajo):
IMG_20190204_213118.jpg
z80
IMG_20190204_213118.jpg (304.37 KiB) Visto 134 veces

Re: Problema raro con algunos juegos en CPC464

Publicado: 04 Feb 2019, 23:24
por catenaccio
La verdad es que no descarto que pueda ser el z80

Por lo visto este modelo que tengo ahora (Z84C0020PEC) es un cmos que puede alcanzar frecuencia de reloj más alta, distinto del original (z8400aps)

Ahora mismo, tras cargar Magica en cinta (mp3), al finalizar la carga el relé suena, pero enseguida vuelve a arrancar, como si no reconociese el final de la carga, solo una pausa. Luego si me pongo a jugar, el relé se vuelve loco y no para de sonar hasta q reseteo

Re: Problema raro con algunos juegos en CPC464

Publicado: 06 Feb 2019, 07:00
por jordi_ab
catenaccio escribió:
04 Feb 2019, 23:24
La verdad es que no descarto que pueda ser el z80

Por lo visto este modelo que tengo ahora (Z84C0020PEC) es un cmos que puede alcanzar frecuencia de reloj más alta, distinto del original (z8400aps)

Ahora mismo, tras cargar Magica en cinta (mp3), al finalizar la carga el relé suena, pero enseguida vuelve a arrancar, como si no reconociese el final de la carga, solo una pausa. Luego si me pongo a jugar, el relé se vuelve loco y no para de sonar hasta q reseteo
He buscado información de los dos Z80, y según lo que he encontrado, son dos procesadores fabricados con distinta tecnología.
El Z8400APS parece ser un Z80 de 4 Mhz NMOS y el Z84C0020PEC un Z80 de 20 Mhz CMOS.
En el hilo del clon de ZX80 hubo problemas por usar Z80 CMOS en lugar de NMOS, con eso no quiero decir que sea el mismo caso pero sería interesante probar con un Z80 NMOS para descartar alguna incompatibilidad con el Amstrad.
viewtopic.php?f=63&t=6348#p112244

Re: Problema raro con algunos juegos en CPC464

Publicado: 06 Feb 2019, 09:56
por catenaccio
jordi_ab escribió:
06 Feb 2019, 07:00
He buscado información de los dos Z80, y según lo que he encontrado, son dos procesadores fabricados con distinta tecnología.
El Z8400APS parece ser un Z80 de 4 Mhz NMOS y el Z84C0020PEC un Z80 de 20 Mhz CMOS.
En el hilo del clon de ZX80 hubo problemas por usar Z80 CMOS en lugar de NMOS, con eso no quiero decir que sea el mismo caso pero sería interesante probar con un Z80 NMOS para descartar alguna incompatibilidad con el Amstrad.
viewtopic.php?f=63&t=6348#p112244
Muchas gracias Jordi, yo también he estado mirando, y no descarto que puedan venir por ahí los problemas. Este proce me lo vendió un compi de este foro, a ver si puedo contactar con el para que haga la prueba con una de sus máquinas.

Aún así voy a ver si consigo un procesador igual al que el tenía (Z8400APS ), creo que en Aliexpress no están muy caros

Re: Problema raro con algunos juegos en CPC464

Publicado: 06 Feb 2019, 10:03
por duca750
catenaccio escribió:
06 Feb 2019, 09:56
jordi_ab escribió:
06 Feb 2019, 07:00
He buscado información de los dos Z80, y según lo que he encontrado, son dos procesadores fabricados con distinta tecnología.
El Z8400APS parece ser un Z80 de 4 Mhz NMOS y el Z84C0020PEC un Z80 de 20 Mhz CMOS.
En el hilo del clon de ZX80 hubo problemas por usar Z80 CMOS en lugar de NMOS, con eso no quiero decir que sea el mismo caso pero sería interesante probar con un Z80 NMOS para descartar alguna incompatibilidad con el Amstrad.
viewtopic.php?f=63&t=6348#p112244
Muchas gracias Jordi, yo también he estado mirando, y no descarto que puedan venir por ahí los problemas. Este proce me lo vendió un compi de este foro, a ver si puedo contactar con el para que haga la prueba con una de sus máquinas.

Aún así voy a ver si consigo un procesador igual al que el tenía (Z8400APS ), creo que en Aliexpress no están muy caros
Hola. Pues la verdad que ni idea, pero por mí no hay problema, si te parece me devuelves ese por ordinario y te mando otro que tengo de un CPC 464 montado y que está más que probado por ordinario también.

Re: Problema raro con algunos juegos en CPC464

Publicado: 06 Feb 2019, 10:06
por catenaccio
duca750 escribió:
06 Feb 2019, 10:03
Hola. Pues la verdad que ni idea, pero por mí no hay problema, si te parece me devuelves ese por ordinario y te mando otro que tengo de un CPC 464 montado y que está más que probado por ordinario también.
Hola Duca, justo ahora te acabo de mandar un MP para ver si podías hacer la prueba e ir descartando posibilidades.

Por el proce no te preocupes, pq funcionar funciona, para conseguir otro 100% compatible (si resulta ser el caso) ya no tengo tanta prisa. Gracias de todas formas :)

Re: Problema raro con algunos juegos en CPC464

Publicado: 06 Feb 2019, 11:13
por duca750
catenaccio escribió:
06 Feb 2019, 10:06
duca750 escribió:
06 Feb 2019, 10:03
Hola. Pues la verdad que ni idea, pero por mí no hay problema, si te parece me devuelves ese por ordinario y te mando otro que tengo de un CPC 464 montado y que está más que probado por ordinario también.
Hola Duca, justo ahora te acabo de mandar un MP para ver si podías hacer la prueba e ir descartando posibilidades.

Por el proce no te preocupes, pq funcionar funciona, para conseguir otro 100% compatible (si resulta ser el caso) ya no tengo tanta prisa. Gracias de todas formas :)
Pues si fuera el caso disculpas, no tengo más iguales al que te mande ahora mismo para probar, la verdad es que antes de mandártelo hice pruebas pero básicas, no pasa nada, yo te mando uno sacado de mi CPC que se que va perfecto y si va en tu equipo perfecto, sino ya debería ser otra cosa. Este es el procesador el cual intentaré mandarlo hoy si me da tiempo.

IMG_20190206_095004-960x540.jpg
IMG_20190206_095004-960x540.jpg (222.36 KiB) Visto 86 veces
El que tienes cuando puedas me lo devuelves por ordinario y listo.