[arreglado] fallo en un Spectrum 48k , TR4 ardiendo

¿Tienes problemas con tu equipo?, preguntanos.

Moderador: Fundadores

Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 8867
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Has thanked: 2 times
Been thanked: 81 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por flopping » 01 Oct 2019, 00:19

Kyp escribió:
30 Sep 2019, 23:45
ardraven escribió:
30 Sep 2019, 23:18
Otra cosa... el 'cuadrado' con letras N y H sobre el altavoz es diferente en mi placa que en esta: http://hardware.speccy.org/imagenes/ord ... sue4B.jpg
En la mía la esquina superior izq y derecha no van soldadas a ningún sitio. Las dos inferiores están soldadas entre ellas. Si las numerásemos así:
Eso depende de la marca de la ROM:
N = NEC
H = Hitachi o GI o Sinclair...

Pero deberías tener dos puentes, los dos N o los dos H.
Exacto, si te falta un puente, es mas que probable que la rom no se active, de todas formas eso no soluciona el problema de la alimentacion, por lo que igual tienes varios problemas en esa placa, pon algunas fotos de la placa, para que veamos como esta en general.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2019, 37 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
España ardraven
El infierno es su lugar
El infierno es su lugar
Mensajes: 108
Registrado: 21 Feb 2019, 00:51
Has thanked: 6 times
Been thanked: 6 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por ardraven » 01 Oct 2019, 00:47

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Avatar de Usuario
Kyp
Hermano de Lucifer
Hermano de Lucifer
Mensajes: 2533
Registrado: 30 Sep 2013, 14:54
Ubicación: Madrid
Has thanked: 37 times
Been thanked: 93 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por Kyp » 01 Oct 2019, 09:58

Ahora que me fijo, levantando una patilla de R62 se aísla +12VA (la que va al circuito de video) pero no +12V (la que va a las memorias). Seguimos teniendo el problema si hay una memoria en corto.

Aislar +12V es complicado, habría que dejar unidos D15, C44 y R59 pero sin conectar a la placa. O eso o cortar la pista que va a las memorias...

La ROM está en zócalo, eso es que la han cambiado. ¿Es ROM original o EPROM?

Avatar de Usuario
llopis
Demonio tercer orden
Demonio tercer orden
Mensajes: 652
Registrado: 05 Jul 2018, 09:43
Ubicación: Asturias
Has thanked: 67 times
Been thanked: 25 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por llopis » 01 Oct 2019, 10:07

Kyp escribió:
01 Oct 2019, 09:58
Aislar +12V es complicado, habría que dejar unidos D15, C44 y R59 pero sin conectar a la placa. O eso o cortar la pista que va a las memorias...
Eso lo he hecho y es fácil de hacer y de reparar más adelante. Es una buena opción.

Pero, si las memorias están tan mal que hace que TR4 se ponga así de caliente, se tiene que notar que alguna esté muy caliente. Si no, no creo que pueda pasar eso, no?

Avatar de Usuario
Kyp
Hermano de Lucifer
Hermano de Lucifer
Mensajes: 2533
Registrado: 30 Sep 2013, 14:54
Ubicación: Madrid
Has thanked: 37 times
Been thanked: 93 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por Kyp » 01 Oct 2019, 10:26

llopis escribió:
01 Oct 2019, 10:07
Kyp escribió:
01 Oct 2019, 09:58
Aislar +12V es complicado, habría que dejar unidos D15, C44 y R59 pero sin conectar a la placa. O eso o cortar la pista que va a las memorias...
Eso lo he hecho y es fácil de hacer y de reparar más adelante. Es una buena opción.
Yo soy más de quitar las memorias porque al final, salvo que sea evidente cual es la que está rota (porque se calienta), es complicado identificar la que falla. Pero quitarlas es delicado sin las herramientas adecuadas... Y la opción de cortar las pistas de alimentación no me gusta, demasiado agresiva.
llopis escribió:
01 Oct 2019, 10:07
Pero, si las memorias están tan mal que hace que TR4 se ponga así de caliente, se tiene que notar que alguna esté muy caliente. Si no, no creo que pueda pasar eso, no?
Bueno, no siempre hay una que se caliente mucho y aun así que esté mal. Y el transistor alternativo que está usando aguanta menos de la mitad de corriente que el original, eso también hace que sea más sensible (que se caliente con más facilidad).

Hace poco a uno de mis Spectrums le pasaba eso mismo, TR4 ardiendo al poco de encender. Como tenía las memorias en zócalo las quité y nada, igual. Es una placa issue3B de esas que son 3 con el mod de fábrica. Lo desmonté pensando que era uno de los diodos grandes pero no, estaban bien. Lo volví a montar y funcionó :)) No se, debía tener algún mal contacto y de toquetear se arregló.

Avatar de Usuario
España ardraven
El infierno es su lugar
El infierno es su lugar
Mensajes: 108
Registrado: 21 Feb 2019, 00:51
Has thanked: 6 times
Been thanked: 6 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por ardraven » 07 Oct 2019, 22:59

Kyp escribió:
01 Oct 2019, 09:58
La ROM está en zócalo, eso es que la han cambiado. ¿Es ROM original o EPROM?
Es un 48k+ castellano, que tiene una EPROM diferente castellanizada de fábrica. ¿O me equivoco?

Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 8867
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Has thanked: 2 times
Been thanked: 81 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por flopping » 07 Oct 2019, 23:06

ardraven escribió:
07 Oct 2019, 22:59
Kyp escribió:
01 Oct 2019, 09:58
La ROM está en zócalo, eso es que la han cambiado. ¿Es ROM original o EPROM?
Es un 48k+ castellano, que tiene una EPROM diferente castellanizada de fábrica. ¿O me equivoco?
Los 48+ no se vendieron con rom en castellano y si es una eprom, menos aun, por lo que sera una version casera o de otro ordenador spectrum posterior a los 48+, por cierto ¿como sabes que esta en castellano?, me refiero a que el equipo no arranca por lo que no puedes verlo.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2019, 37 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
España ardraven
El infierno es su lugar
El infierno es su lugar
Mensajes: 108
Registrado: 21 Feb 2019, 00:51
Has thanked: 6 times
Been thanked: 6 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por ardraven » 07 Oct 2019, 23:26

Nuevos avances:

He levantado los componentes que ya hemos comentado (R29, D19 y R62) y cortado la pista que sale de C44 hacia las memorias. Espero haber cortado la pista correcta.... 8-)

Imagen Imagen

TR4 se sigue calentando igual.
Las memorias en el pin de 12v miden unos 4v.
Justo antes del corte, en el (+) de C44, se miden 4v.

¿Podrían ser los TR4/TR5?!?? Lo he mirado varias veces, y creo que TR4 y TR5 están bien montados. Podría volver a cambiarlos por unos nuevos.

¿Podría estar roto el transformador/coil? ¿Los diodos de la zona de alimentación?

Avatar de Usuario
España ardraven
El infierno es su lugar
El infierno es su lugar
Mensajes: 108
Registrado: 21 Feb 2019, 00:51
Has thanked: 6 times
Been thanked: 6 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por ardraven » 07 Oct 2019, 23:39

flopping escribió:
07 Oct 2019, 23:06
ardraven escribió:
07 Oct 2019, 22:59
Kyp escribió:
01 Oct 2019, 09:58
La ROM está en zócalo, eso es que la han cambiado. ¿Es ROM original o EPROM?
Es un 48k+ castellano, que tiene una EPROM diferente castellanizada de fábrica. ¿O me equivoco?
Los 48+ no se vendieron con rom en castellano y si es una eprom, menos aun, por lo que sera una version casera o de otro ordenador spectrum posterior a los 48+, por cierto ¿como sabes que esta en castellano?, me refiero a que el equipo no arranca por lo que no puedes verlo.
Pues entonces estoy mezclando lo que yo he creido que era con lo que es en realidad... Visto por la zona de soldaduras, el Z80 y el zocalo parecen soldados fuera de fábrica, como si lo hubieran arreglado en servicio técnico.

Por supuesto, tienes razón en que me he debido de inventar lo del ZX en castellano porque verlo, no lo he podido ver. :-X

¿Lo de llevar la Ñ no se hacía con una ROM especial que era una EPROM?

Avatar de Usuario
España ardraven
El infierno es su lugar
El infierno es su lugar
Mensajes: 108
Registrado: 21 Feb 2019, 00:51
Has thanked: 6 times
Been thanked: 6 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por ardraven » 19 Oct 2019, 20:42

Al final, era un error de pardillo...

TR4 y TR5 montados del revés...! y eso que revisé los datasheet. Error mío.

Tras eso, el spectrum enciende y no se caliente.

Falla el beeper... pero cambiando el Diodo D9, vuelve a funcionar.

Así que, otro 48k+ funcionando!

Gracias por la ayuda

Responder

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados