Página 4 de 4

Re: Spectrum +2 no se enciende correctamente hasta que se calienta y falla el sincronismo vertical

Publicado: 07 Nov 2019, 00:03
por Bone
No recuerdo si has dicho ya que valor tienes en la línea de +5v. Si no son +5v y esta por debajo de 4,5v.......podrias conectar el tester a la línea de 5v dejandolo conectado esos cinco minutos y ver si va subiendo el voltaje. Como dice @Kyp, sin osciloscopio vas a ir bastante a ciegas, pueden ser muchas cosas...desde el PCF1306p hasta algún ....Acabo de ver las capturas que has colgado antes, en la primera que pones con el DIN8 al aire, en la placa, más concretamente en el bus de expansión, en el borde derecho pin 28B (A11) una cosa rara...¿que es?

Re: Spectrum +2 no se enciende correctamente hasta que se calienta y falla el sincronismo vertical

Publicado: 07 Nov 2019, 00:11
por Bone
Ahhh! Por cierto, has dicho que has repasado muchas soldaduras, ¿y las del cristal? ;)

Re: Spectrum +2 no se enciende correctamente hasta que se calienta y falla el sincronismo vertical

Publicado: 07 Nov 2019, 12:02
por javier2112
Si tienes la posibilidad, reemplaza el regulador, aunque sea temporalmente por un 7805 normal (en ese caso, con la unidad de cinta desconectada), solo para comprobar que el equipo arranca en frío.


Saludos.

Edito. Creo que el problema es que no tiene el regulador adecuado. El que indicas tú L7805CV es de 1A, mientras que el que debería llevar es el L78S05CV, de 2A.


Saludos.

Re: Spectrum +2 no se enciende correctamente hasta que se calienta y falla el sincronismo vertical

Publicado: 08 Nov 2019, 12:10
por Nextric
Bueno, seguimos con las incógnitas. He repasado las soldaduras del cristal y al intentar revisar la resistencia R53 se me ha partido. La he sustituido por una de 220K de los chinos, que no me da nada de confianza, y ahora tenemos otro comportamiento. Ahora arranca de primeras correctamente, pero al rato se corrompe y el pulsador falla unas veces si u otra no. Además encima me he llevado parte del agujerito de la parte superior de la placa y de la pista, así que la he puenteado con el condensador C36.

Lo del bus de expansión, era una mota de mierda, nada mas.

Me he traído mi viejo gomas, así que por lo menos voy a revisar que el Z80 funcione correctamente intercambiándolo para ir descartando cosas.

Re: Spectrum +2 no se enciende correctamente hasta que se calienta y falla el sincronismo vertical

Publicado: 08 Nov 2019, 12:53
por Kyp
Para descartar el reset puedes hacer lo siguiente. Quita el condensador C36 y pon una resistencia R53 de unos 10K. Al encender tendrás que resetear manualmente el Spectrum pero luego ya no debería influir eso en nada (el condensador es para resetear al encender y la resistencia para mantener el reset a 1 lógico mientras no se pulse el botón). Así no influye el condensador si está tocado. Y también comprueba que al desaparecer el taladro no se ha quedado sin conectar alguna pista porque si se queda 'flotando' el reset puede hacer cosas raras. Y que el botón de reset no esté roto.

Re: Spectrum +2 no se enciende correctamente hasta que se calienta y falla el sincronismo vertical

Publicado: 08 Nov 2019, 13:11
por Nextric
Mmmm, me parece buena solución Kyp. Gracias!!!!! Esta noche lo pruebo.