Fallo ZX81 Issue 3 - Video falla al escribir programas

¿Tienes problemas con tu equipo?, preguntanos.

Moderador: Fundadores

Responder
Avatar de Usuario
España ardraven
El infierno es su lugar
El infierno es su lugar
Mensajes: 126
Registrado: 21 Feb 2019, 00:51
Has thanked: 7 times
Been thanked: 7 times
Contactar:

Fallo ZX81 Issue 3 - Video falla al escribir programas

Mensaje por ardraven » 24 Oct 2019, 19:56

Buenas...

Tengo un ZX81 Issue3 con el mod de video compuesto y fuente original, y he conseguido recuperar el teclado arreglando la membrana.

Aún no he podido probar el sonido (si carga o graba juegos), eso lo haré más adelante por falta de tiempo.

He mirado en guías de reparación de ZX81 y no he visto nada, a ver si alguien sabe qué he de mirar.

Los síntomas son los siguientes: arranca normal, la K se ve perfectamente y cualquier comando se ejecuta correctamente. El problema es que según voy escribiendo un programa, el ordenador se va 'degradando'. De modo que la K aparece como borrosa y con una línea en la parte inferior. Y lo peor, el video deja de responder y se vuelve inestable. Si ejecutas un simple programa donde haya un bucle de salida de textos en pantalla, la pantalla se va a negro y únicamente vuelve al comando K si paras el programa o pulsas 'space'.
Pero si en esa situación introduzco el comando 'NEW', todo vuelve a la normalidad.

Es el único ZX81 que tengo, por lo que la ULA no la puedo probar en otro equipo.

Puede ser un problema de memorias? de la ULA?

Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 8942
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Has thanked: 2 times
Been thanked: 108 times
Contactar:

Re: Fallo ZX81 Issue 3 - Video falla al escribir programas

Mensaje por flopping » 24 Oct 2019, 21:05

Parece un problema de ram, por lo que cuentas tiene toda la pinta, de hecho el ZX81 solo lleva 4 integrados, ram, rom, ula y micro, también podría ser el micro, pero no parece ya que responde a las instrucciones y demás, por lo que si se van degradando los datos parece indicar que es un problema de ram.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2020, 38 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
España ardraven
El infierno es su lugar
El infierno es su lugar
Mensajes: 126
Registrado: 21 Feb 2019, 00:51
Has thanked: 7 times
Been thanked: 7 times
Contactar:

Re: Fallo ZX81 Issue 3 - Video falla al escribir programas

Mensaje por ardraven » 10 Nov 2019, 20:53

Actualizo: antes de cambiar la memoria (ya que me pongo, la actualizaré a 16k) he cambiado los tres condensadores. Sigue igual.

Cuando saque tiempo, le actualizaré la memoria y video de alta resolución, a ver si mejora el comportamiento.

Responder

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 3 invitados