Mod de Video + 32KB de RAM + HiRes para ZX81

Moderador: Fundadores

Avatar de Usuario
España_Comunidad_Valenciana wilco2009
Hermano de Lucifer
Hermano de Lucifer
Mensajes: 7642
Registrado: 01 Abr 2013, 23:47
Ubicación: Valencia
Has thanked: 36 times
Been thanked: 32 times
Contactar:

Re: Mod de Video + 32KB de RAM + HiRes para ZX81

Mensaje por wilco2009 » 25 Feb 2019, 00:16

Me tiene confuso una cosa, no te tengo anotado como que te haya vendido una placa, por lo que pensaba que te habías hecho el mod de video tú mismo con el esquema de jose_leandro.

De todas formas, acabo de ver que en tu foto el punto donde has cogido el "video in" no es correcto, y la culpa la tiene que la foto que colgué es confusa, por lo que volveré a colgar otra más clarificante.

El punto de sodadura el "video in" es el segundo cable empezando por la derecha de los que entran al modulador (el primero es +5V y el segundo el video).
En la foto que has colgado no hay ningun cable entrando al modulador más que los tuyos (supongo que los habrás retirado), por lo que no sé si originalmente iba igual que en un zx81 o no.

El punto alternativo de conexión del "video in" es la parte derecha de R29, aunque en tu foto no se ve, y lo mismo en tu version de placa no es igual.
"Aprender a volar es todo un arte. Aunque sólo hay que cogerle el truco. Consiste en tirarse al suelo y fallar".

Douglas Adams. Guía del autoestopista galáctico.

Avatar de Usuario
Quickie
Aspirante a demonio
Aspirante a demonio
Mensajes: 227
Registrado: 21 Sep 2017, 19:58
Has thanked: 7 times
Been thanked: 7 times
Contactar:

Re: Mod de Video + 32KB de RAM + HiRes para ZX81

Mensaje por Quickie » 25 Feb 2019, 00:30

Hola Wilco,

Gracias por actualizar el tema y explicar la causa del problema :)
Estas en lo cierto, de momento no he adquirido (aún) tu mod porqué no tengo un ZX81. Éste es de un colega (drchizo) que sí te compró el kit y me confió la instalación del mod ;)

En cuanto a la deducción que comentabas, es correcta: retiré los cables de entrada del modulador y únicamente hice pasar el cable verde de salida de vídeo compuesto que sale de la pcb del mod (Video Out).
En la PCB ISS3 del TS1000 la R29 está en otra ubicacion (justo bajo la ULA). Aun así, probaré el punto que comentas y actualizo.

Gracias.
Imagen

Avatar de Usuario
España_Comunidad_Valenciana wilco2009
Hermano de Lucifer
Hermano de Lucifer
Mensajes: 7642
Registrado: 01 Abr 2013, 23:47
Ubicación: Valencia
Has thanked: 36 times
Been thanked: 32 times
Contactar:

Re: Mod de Video + 32KB de RAM + HiRes para ZX81

Mensaje por wilco2009 » 25 Feb 2019, 00:40

Quickie escribió:
25 Feb 2019, 00:30
Hola Wilco,

Gracias por actualizar el tema y explicar la causa del problema :)
Estas en lo cierto, de momento no he adquirido (aún) el tu mod porqué no tengo un ZX81. Éste es de un colega (drchizo) que sí te compró el kit y me confió la instalación del mod ;)

En cuanto a la deducción que comentabas, es correcta: retiré los cables de entrada del modulador y únicamente hice pasar el cable verde de salida de vídeo compuesto que sale de la pcb del mod (Video Out).
En la PCB ISS3 del TS1000 la R29 está en otra ubicacion (justo bajo la ULA). Aun así, probaré el punto que comentas y actualizo.

Gracias.
Ante la duda hay un punto seguro de donde puedes sacar la señal de vídeo, el pin 16 de la ULA. Ese seguro que es igual en todos los ZX81.
Comprueba con el polimetro si los puntos propuestos tienen continuidad con ese pin de la ULA para asegurarte.
"Aprender a volar es todo un arte. Aunque sólo hay que cogerle el truco. Consiste en tirarse al suelo y fallar".

Douglas Adams. Guía del autoestopista galáctico.

Avatar de Usuario
Quickie
Aspirante a demonio
Aspirante a demonio
Mensajes: 227
Registrado: 21 Sep 2017, 19:58
Has thanked: 7 times
Been thanked: 7 times
Contactar:

Re: Mod de Video + 32KB de RAM + HiRes para ZX81

Mensaje por Quickie » 25 Feb 2019, 00:52

Hola.

Comprobé continuidad con el punto que comentabas y R29 y efectivamente, por ahí he podido sacar video.
¡Ya se vé! :) Gracias

Aun así, es curioso porqué el se ve la imagen durante 4-5 segundos, se ve 1-2 frames en negro y vuelve la imagen.
En algún momento incluso el texto del cursor se veía amarillento en vez de negro. ¿Puede regularse eso quizas con los potenciómetros?

EDIT: Me contesto a mi mismo: Ajustando el potenciómetro de la derecha he obtenido una imagen nítida y estable.
Todo perfecto. ¡Mil gracias!
Imagen

Avatar de Usuario
España_Comunidad_Valenciana wilco2009
Hermano de Lucifer
Hermano de Lucifer
Mensajes: 7642
Registrado: 01 Abr 2013, 23:47
Ubicación: Valencia
Has thanked: 36 times
Been thanked: 32 times
Contactar:

Re: Mod de Video + 32KB de RAM + HiRes para ZX81

Mensaje por wilco2009 » 25 Feb 2019, 01:05

Quickie escribió:
25 Feb 2019, 00:52
Hola.

Comprobé continuidad con el punto que comentabas y R29 y efectivamente, por ahí he podido sacar video.
¡Ya se vé! :) Gracias

Aun así, es curioso porqué el se ve la imagen durante 4-5 segundos, se ve 1-2 frames en negro y vuelve la imagen.
En algún momento incluso el texto del cursor se veía amarillento en vez de negro. ¿Puede regularse eso quizas con los potenciómetros?

EDIT: Me contesto a mi mismo: Ajustando el potenciómetro de la derecha he obtenido una imagen nítida y estable.
Todo perfecto. ¡Mil gracias!
Me alegro, a disfrutarlo
"Aprender a volar es todo un arte. Aunque sólo hay que cogerle el truco. Consiste en tirarse al suelo y fallar".

Douglas Adams. Guía del autoestopista galáctico.

Avatar de Usuario
hamham
Demonio segundo orden
Demonio segundo orden
Mensajes: 1855
Registrado: 02 Abr 2013, 18:17
Ubicación: Alicante
Has thanked: 4 times
Been thanked: 7 times
Contactar:

Re: Mod de Video + 32KB de RAM + HiRes para ZX81

Mensaje por hamham » 26 Feb 2019, 22:39

Paquete recibido, :D
Voy a esperar a recibir mi recién adquirida estación de desoldar zd 915 , de la que todos habláis tan bien para retirar las memorias y lo pruebo.
Estoy deseando saber si mi zx81 funciona, nunca logre sintonizarlo y se veía toqueteadas las soldaduras por la zona de video.
Saludos y gracias por todo

Avatar de Usuario
España_La_Rioja iturbez
Demonio tercer orden
Demonio tercer orden
Mensajes: 765
Registrado: 01 Feb 2014, 18:56
Has thanked: 6 times
Been thanked: 10 times
Contactar:

Re: Mod de Video + 32KB de RAM + HiRes para ZX81

Mensaje por iturbez » 27 Feb 2019, 22:40

Recogido el mío en Correos esta tarde.
Muchas gracias.
A la cola de montajes va...

Avatar de Usuario
España_Comunidad_Valenciana wilco2009
Hermano de Lucifer
Hermano de Lucifer
Mensajes: 7642
Registrado: 01 Abr 2013, 23:47
Ubicación: Valencia
Has thanked: 36 times
Been thanked: 32 times
Contactar:

Re: Mod de Video + 32KB de RAM + HiRes para ZX81

Mensaje por wilco2009 » 28 Feb 2019, 00:55

Van llegando.... :)
"Aprender a volar es todo un arte. Aunque sólo hay que cogerle el truco. Consiste en tirarse al suelo y fallar".

Douglas Adams. Guía del autoestopista galáctico.

Jason_rg
Demonio tercer orden
Demonio tercer orden
Mensajes: 540
Registrado: 16 May 2015, 20:32
Ubicación: Guipuzcoa
Been thanked: 8 times
Contactar:

Re: Mod de Video + 32KB de RAM + HiRes para ZX81

Mensaje por Jason_rg » 28 Feb 2019, 11:25

Hola wilco

Paquete recibido, todo ok.
Muchas gracias.

Saludos

Enviado desde mi SM-G950F mediante Tapatalk


Avatar de Usuario
Isle of Man jjsaenz1969
Demonio tercer orden
Demonio tercer orden
Mensajes: 719
Registrado: 22 Mar 2015, 00:41
Ubicación: Vitoria
Has thanked: 24 times
Been thanked: 12 times
Contactar:

Re: Mod de Video + 32KB de RAM + HiRes para ZX81

Mensaje por jjsaenz1969 » 28 Feb 2019, 17:23

Paquete recibido también aquí.
Ahora a montarlo, :o peeeero, acabo de recordar que ya no tengo el ZX81.
Lo vendí hace tiempo, aquí en el foro.

Responder

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 3 invitados