CPC Dandanator Mini! Hilo de dudas

Moderador: Fundadores

Avatar de Usuario
Australia dandare
Hermano de Lucifer
Hermano de Lucifer
Mensajes: 3514
Registrado: 09 Feb 2016, 15:09
Ubicación: I Register
Has thanked: 8 times
Been thanked: 85 times
Contactar:

Re: CPC Dandanator Mini! Hilo de dudas

Mensaje por dandare » 12 Ene 2019, 11:59

Qué efecto más peculiar. De verdad que no se me ocurre cómo es posible que pase eso.
El dandanator no tiene la capacidad de impedir cambios de rom alta, salvo que explícitamente se ponga una ahí y se le diga que se mantenga ,cosa que es imposible que esté pasando, puesto que el basic interno carga, ni interfiere en los comandos de cambio de rom. (Si tenemos acceso a deshabilitar la rom, pero no puede discriminar entre números de rom alta, o todas o ninguna)

Lo único que se me ocurre es que sea un efecto raro producido por algún defecto de hw. Bien porque el conector no está limpio del todo, bien porque hay algún tipo de fallo en el cartucho.

No creo que sea un problema de alimentación porque el cartucho consume realmente poco.


Vamos a hacer estos pasos:
1) hay una remotisima posibilidad de que el arranque del firm esté mandando comandos raros al dandanator. Eso no debería pasar, pero por probar, salid a basic pulsando esc desde el menu de los mojons, no manteniendo pulsado el botón central.
2) por favor limpiad muy bien el conector edge
3) si podéis, probadlo en otro 6128
4) probadlo con otra fuente, aunque sea sólo la de 5v (no pongáis la de 12 de otra fuente, solo una fuente a la vez)
5) si todo esto falla, vemos la opción de que me mandéis un cartucho para analizarlo.
Imagen
Imagen

Avatar de Usuario
España javier2112
Demonio tercer orden
Demonio tercer orden
Mensajes: 546
Registrado: 30 Oct 2014, 12:36
Ubicación: Málaga
Has thanked: 10 times
Been thanked: 4 times
Contactar:

Re: CPC Dandanator Mini! Hilo de dudas

Mensaje por javier2112 » 12 Ene 2019, 12:55

dandare escribió:
12 Ene 2019, 11:59
Qué efecto más peculiar. De verdad que no se me ocurre cómo es posible que pase eso.
El dandanator no tiene la capacidad de impedir cambios de rom alta, salvo que explícitamente se ponga una ahí y se le diga que se mantenga (cosa que es imposible que esté pasando, puesto que el basic interno carga, ni interfiere en los comandos de cambio de rom. (Si tenemos acceso a deshabilitar la rom, pero no puede discriminar entre números de rom alta, o todas o ninguna)

Lo único que se me ocurre es que sea un efecto raro producido por algún defecto de hw. Bien porque el conector no está limpio del todo, bien porque hay algún tipo de fallo en el cartucho.

No creo que sea un problema de alimentación porque el cartucho consume realmente poco.


Vamos a hacer estos pasos:
1) hay una remotisima posibilidad de que el arranque del firm esté mandando comandos raros al dandanator. Eso no debería pasar, pero por probar, salid a basic pulsando esc desde el menude los mojons, no manteniendo pulsado el botón central.
2) por favor limpiad muy bien el conector edge
3) si podéis, probadlo en otro 6128
4) probadlo con otra fuente, aunque sea sólo la de 5v (no pongáis la de 12 de otra fuente, dólo una fuente a la vez)
5) si todo esto falla, vemos la opción de que me mandéis un cartucho para analizarlo.
Buenas.

Al ordenador le he dado un repaso en las últimas semanas, y entre otras cosas, he limpiado todo concienzudamente, por lo que los conectores están como nuevos.

Por otra parte, las pruebas las he hecho con 2 fuentes: 1º con una de PC y después con la que uso habitualmente, que es de un Spectrum +3. En ambos casos, 1º con los 2 voltajes y luego solo con 5V. Si luego quito el Dandanator los comandos de disco funcionan como debería.

Hace un momento he probado a salir con ESC al BASIC y el efecto es el mismo que el que ha motivado mi consulta, así que no veo qué más puede estar pasando. Aunque no lo has mencionado en ningún momento, doy por sobreentendido que este efecto no te pasa a ti ni a ninguno de los testers (de hecho también he probado con emulador y funciona correctamente).

Tengo un álbum donde he puesto las fotos que he ido haciendo durante la "restauración" y mejora del CPC. Lo enlazo aquí por si sirve de ayuda:
https://photos.app.goo.gl/e6jJ9RbYgP8hbj5T9

Quiero aclarar un par de cosas:
1) En una de las fotos se ve que he añadido un reset. En realidad todas esas pruebas las he hecho antes de tener ese añadido.
2) En una de las fotos se ve un comando dir desde BASIC. Es un error. Eso nunca funcionará.

Sólo por especular, ¿no sería posible que el firmware en mi CPC haga alguna comprobación sobre ciertos puertos y como consecuencia de ello, desactive todo lo relativo con el disco? ¿Podría ser que según la versión de placa el resultado de consultar esos puertos sea distinto, como sucede en los Spectrums? En las fotos hay alguna de la placa, por si esto pudiera servir de ayuda.


Saludos.

Avatar de Usuario
Zambia DrLivingstone
Le gustan las llamas
Le gustan las llamas
Mensajes: 85
Registrado: 29 May 2016, 16:37
Has thanked: 6 times
Been thanked: 1 time
Contactar:

Re: CPC Dandanator Mini! Hilo de dudas

Mensaje por DrLivingstone » 12 Ene 2019, 13:38

:(
Nada, pulsando ESC el efecto es el mismo, a mí cuando doy un CAT me indica el "Press play..." y no funciona |a ni |dir ni como si fuera un 464. Si quito el Dandanator los comandos del Amsdos de disco funcionan correctamente.
Lo he probado con otro 6128 de un vecino y ocurre lo mismo.
Los conectores están bien, en mi 6128 tengo un M4 y funciona correctamente no he tenido ningún problema.
Aunque la parte de carga del Dandanator funciona bien y es una gozada y la canción Dune Buggy de Oliver Onions lo es aún más, cuando te sales al Basic para hacer algo no tienes más remedio que quitarlo :~( :~( :~( :~( :~( :~( :~( :~(
Así que hice lo que la cobardía moral y el falso orgullo consideraron más apropiado: caminé hacia él, me quité el sombrero y dije:Doctor Livingstone, supongo

Avatar de Usuario
Australia dandare
Hermano de Lucifer
Hermano de Lucifer
Mensajes: 3514
Registrado: 09 Feb 2016, 15:09
Ubicación: I Register
Has thanked: 8 times
Been thanked: 85 times
Contactar:

Re: CPC Dandanator Mini! Hilo de dudas

Mensaje por dandare » 12 Ene 2019, 13:43

DrLivingstone escribió:
12 Ene 2019, 13:38
...
Lo he probado con otro 6128 de un vecino y ocurre lo mismo...
Esto es importante y apunta a fallo hw del cartucho. Lo mismo te digo, hablamos en un par de semanas para ver si me lo puedes mandar de vuelta.
Imagen
Imagen

Avatar de Usuario
Australia dandare
Hermano de Lucifer
Hermano de Lucifer
Mensajes: 3514
Registrado: 09 Feb 2016, 15:09
Ubicación: I Register
Has thanked: 8 times
Been thanked: 85 times
Contactar:

Re: CPC Dandanator Mini! Hilo de dudas

Mensaje por dandare » 12 Ene 2019, 13:44

Contestando a Javier, que no sé qué ha pasado con el post que hice hace unos minutos:

Sí, funciona correctamente en todos los equipos que hemos probado.

El dandanator no responde a puertos. No ro cómo puede afectarle una petición de ese tipo.

Por otro lado, al arrancar el basic sabemos que el KL ROM WALK del firmware (Lo ha estado analizando overCLK) lo está haciendo y el basic contesta, pero el amsdos parece que no.

Un enigma curioso. Siguiente paso es ver si el dandanator tiene algún tipo de problema HW que pueda estar originando esto.

Tal vez un componente defectuoso o mal puesto. Las placas las montaron en una empresa externa y yo comprobé todos los aspectos de funcionamiento principales para cada una, incluso que arrancara en basic. La parte del amsdos no lo hice en cada cartucho.

Estoy con un lío importante ahora, pero en febrero tendré algo de tiempo para revisar eso.
Hablamos para que me envíes el cartucho.
Entre tanto, si puedes, pruébalo en otro 6128 distinto.
Imagen
Imagen

Avatar de Usuario
llopis
Demonio tercer orden
Demonio tercer orden
Mensajes: 652
Registrado: 05 Jul 2018, 09:43
Ubicación: Asturias
Has thanked: 67 times
Been thanked: 25 times
Contactar:

Re: CPC Dandanator Mini! Hilo de dudas

Mensaje por llopis » 12 Ene 2019, 14:08

DrLivingstone escribió:
12 Ene 2019, 10:21
A mí me ocurre lo mismo en mi 6128. Lo he recibido la semana pasada, y ahora cacharreando al entrar en modo Basic ninguno de los comandos RSX del Amsdos funciona.
Si colocas un CAT te sale el "press play then any key" se comporta como un 464.
Lo acabo de probar por si acaso y... a mi también me pasa! Además, tengo 2 Dandanators, y me pasa con los dos.

Avatar de Usuario
Australia dandare
Hermano de Lucifer
Hermano de Lucifer
Mensajes: 3514
Registrado: 09 Feb 2016, 15:09
Ubicación: I Register
Has thanked: 8 times
Been thanked: 85 times
Contactar:

Re: CPC Dandanator Mini! Hilo de dudas

Mensaje por dandare » 12 Ene 2019, 14:13

llopis escribió:
12 Ene 2019, 14:08
DrLivingstone escribió:
12 Ene 2019, 10:21
A mí me ocurre lo mismo en mi 6128. Lo he recibido la semana pasada, y ahora cacharreando al entrar en modo Basic ninguno de los comandos RSX del Amsdos funciona.
Si colocas un CAT te sale el "press play then any key" se comporta como un 464.
Lo acabo de probar por si acaso y... a mi también me pasa! Además, tengo 2 Dandanators, y me pasa con los dos.
Caray!, pues tengo que mirar esto con detalle. De verdad que no se me ocurre una posible causa.
Imagen
Imagen

Avatar de Usuario
llopis
Demonio tercer orden
Demonio tercer orden
Mensajes: 652
Registrado: 05 Jul 2018, 09:43
Ubicación: Asturias
Has thanked: 67 times
Been thanked: 25 times
Contactar:

Re: CPC Dandanator Mini! Hilo de dudas

Mensaje por llopis » 12 Ene 2019, 14:18

dandare escribió:
12 Ene 2019, 14:13
Caray!, pues tengo que mirar esto con detalle. De verdad que no se me ocurre una posible causa.
La verdad es que no me acuerdo de los detalles, pero no puede ser que la ROM que contiene los comandos del disco no sea inicializada correctamente? Me imagino que si quito ese chip, quizás pase eso exáctamente igual.

Avatar de Usuario
España javier2112
Demonio tercer orden
Demonio tercer orden
Mensajes: 546
Registrado: 30 Oct 2014, 12:36
Ubicación: Málaga
Has thanked: 10 times
Been thanked: 4 times
Contactar:

Re: CPC Dandanator Mini! Hilo de dudas

Mensaje por javier2112 » 12 Ene 2019, 16:28

Dandare, no hay prisa porque no es un problema importante; más que nada es curiosidad por saber.

En vista de lo que se a dicho por aqui, me inclino por un fallo en el montaje o componentes defectuosos, si se confirma que afecta a los de la tirada y no a los prototipos (y vete tu a saber por qué afecta de esa manera).

Avatar de Usuario
Zambia DrLivingstone
Le gustan las llamas
Le gustan las llamas
Mensajes: 85
Registrado: 29 May 2016, 16:37
Has thanked: 6 times
Been thanked: 1 time
Contactar:

Re: CPC Dandanator Mini! Hilo de dudas

Mensaje por DrLivingstone » 12 Ene 2019, 16:58

Igual digo que javier2112, yo creo que es un problema del hw si sólo lo hemos tenido unos pocos.
Así que hice lo que la cobardía moral y el falso orgullo consideraron más apropiado: caminé hacia él, me quité el sombrero y dije:Doctor Livingstone, supongo

Responder

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado