Tarjeta de sonido interna OPL3 ISA 8 bits (FUNCIONANDO)

Moderador: Fundadores

Avatar de Usuario
España_País_Vasco spark2k06
Demonio tercer orden
Demonio tercer orden
Mensajes: 906
Registrado: 16 Oct 2017, 10:18
Has thanked: 34 times
Been thanked: 118 times
Contactar:

Re: Tarjeta de sonido interna OPL3 ISA 8 bits

Mensaje por spark2k06 » 11 Jun 2020, 17:03

Muchas gracias @flopping, anoto todas tus sugerencias y en cuanto tenga un rato lo compruebo. Ya os cuento algo! :-)

Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 9243
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Has thanked: 2 times
Been thanked: 184 times
Contactar:

Re: Tarjeta de sonido interna OPL3 ISA 8 bits

Mensaje por flopping » 11 Jun 2020, 22:48

Tambien podria ser, (aunque no creo, pero bueno en esto de la electronica a veces hay cosas muy raras), el IC U6, que es los 4 operacionales TL072, digo que no creo, ya que parece que funcionan, ya que sale la musica a un buen volumen, pero quiza podria tener algun problema, revisa tambien la masa de este integrado, ya que me parece que el problema podria estar en alguna masa que no esta correctamente conectada a la masa general, vamos, yo de ti, revisaria con un polimetro, todas las masas de la placa y ver si estan todas unidas entre si y a la vez a la masa general de la placa, esto es facil de comprobar, ya que son unas pocas mediciones y ademas se hace rapido, venga, a ver si hay suerte y la sacas adelante.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2020, 38 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
España_País_Vasco spark2k06
Demonio tercer orden
Demonio tercer orden
Mensajes: 906
Registrado: 16 Oct 2017, 10:18
Has thanked: 34 times
Been thanked: 118 times
Contactar:

Re: Tarjeta de sonido interna OPL3 ISA 8 bits

Mensaje por spark2k06 » 12 Jun 2020, 07:24

Tanto TL072 como TL074 no tienen masa, trabajan a +/- 12V y así los tengo conectados en el BUS ISA:

Imagen

Todas las resistencias medidas y OK, todos los componentes (condensadores, resto de ICs, etc...) tienen su punto de masa común a través uno u otro PAD GND disponibles del BUS ISA. Faltaría medir los condensadores de 1uF, pero no tengo medidor, lo mediré mediante arduino. (Habrá que hacerse de unos medidores baratos que venden en Aliexpress/eBay y que miden también el ESR entre otras cosas)

El tema de los valores altos de las resistencias, creo que vas a tener razón ahora que veo el vídeo de LGR de la Resound OPL3 que acerca mucho la PCB a la cámara. Parece que los de 10K podrían ser de 1K y los de 100K de 10K:



No se si lo han podido dejar sin corregir a propósito o qué, porque la primera confusión ya me la comí con el IC 74HCT245 (TTL compatible) que se ve claramente en las fotos y el vídeo que es éste pero en el esquema no lo corrigieron y lo dejaron como un 74HC245 (CMOS), lo cual hace que no funcione bien tampoco al de poco tiempo funcionando y se oigan chascarridos, gracias a @Distwave en este sentido que se percató de ello.

Próxima tarea, más que medir el condensador de 1uF será sustituir resistencias, gracias por darte cuenta de este aspecto @flopping... tiene todo el sentido.

Edito: Ah, pues no... es otra nomenclatura, con 4 dígitos 1002 sí es 10K y 1003 sí es 100K... pues no sé, habrá que medir esos condensadores de 1uF. Tal y como se ve en el vídeo, la Resound OPL3 está funcionando correctamente con esos valores.

Avatar de Usuario
España_País_Vasco spark2k06
Demonio tercer orden
Demonio tercer orden
Mensajes: 906
Registrado: 16 Oct 2017, 10:18
Has thanked: 34 times
Been thanked: 118 times
Contactar:

Re: Tarjeta de sonido interna OPL3 ISA 8 bits

Mensaje por spark2k06 » 12 Jun 2020, 15:06

El valor de 1uF de estos condensadores WIMA es correcto... seguiré dandole una vuelta al tema:

Imagen

Imagen

Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 9243
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Has thanked: 2 times
Been thanked: 184 times
Contactar:

Re: Tarjeta de sonido interna OPL3 ISA 8 bits

Mensaje por flopping » 12 Jun 2020, 15:11

¿Tu polimetro no tiene la opcion de medir condensadores? es un simbólito de un condensador, no es una opcion muy comun, pero tanpoco tan rara, pero bueno, no importa, sigo pensando que tu problema es de masas, mas concretamente la falta de conexión de alguna(s).

Haz unas pruebas, con la placa conectada, da igual si es recien enchufada o lleva ya un rato, mide la tension entre el positivo del TL074 y el punto de union entre R2 y R4, que se supone que es masa, deberia de darte +12v, mide tambien entre el punto de union de R8 y R10, que se supone que tambien es masa, tambien deberia de darte +12v, tambien mide entre positivo y la masa de R6 y lo mismo con R12, en todos los casos la medida deberia de ser +12v y lo mismo descrito anteriormente con el TL072.


Ahora haz las mismas mediciones, pero entre la alimentación negativa en el pin correspondiente de cada chip y esos puntos de masa comentados, deberia de medirte en todos los casos -12v, si en algun punto no te da los valores esperados, es que te falta alguna conexion entre masas, si te da los valores esperados, hay que buscar en otros puntos, pero bueno, primero veamos los resultados y ya vamos deduciendo cosas.

Edito, nos hemos cruzado los mensajes, mira lo que te comento a ver, como decia, no creo que sean los condensadores, ya que ese tipo de condensadores suelen ser buenos y precisos.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2020, 38 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
España_País_Vasco spark2k06
Demonio tercer orden
Demonio tercer orden
Mensajes: 906
Registrado: 16 Oct 2017, 10:18
Has thanked: 34 times
Been thanked: 118 times
Contactar:

Re: Tarjeta de sonido interna OPL3 ISA 8 bits

Mensaje por spark2k06 » 13 Jun 2020, 07:54

Ya tengo acotado el problema... únicamente son los condensadores de 1uF primarios de ambos canales los que se quedan cargados (verificado con polimetro, una vez cargados tienen 2,5V aproximadamente):

Imagen

Estos tienen un punto común de entrada de sonido con LIN y RIN a través de una resistencia de 10K como se puede apreciar en la imagen. A su vez, llevan otra resistencia de 100K a GND que incluso he probado a anularla para que RMIX/LMIX estén conectado a GND sólo a través de la resistencia de 10K, y nada... no se descargan estos condensadores. Tal vez poniendo unas resistencias de 10K adicionales en los pines 3 y 5 de TL072 que lo lleven a GND, al igual que los condensadores de 1uF secundarios? Pero si es así, por qué demonios no los lleva el diseño de la Resound OPL y funciona bien? No lo entiendo...

Seguiré haciendo pruebas. @flopping, respecto a mi polimetro... es éste, 23 años de uso y funciona como el primer día, me lo dieron en un cursillo de electrónica que hice de chaval y le tengo demasiado cariño como para deshacerme de él :D :

Imagen

Detalles técnicos de la Resound OPL:


Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 9243
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Has thanked: 2 times
Been thanked: 184 times
Contactar:

Re: Tarjeta de sonido interna OPL3 ISA 8 bits

Mensaje por flopping » 13 Jun 2020, 11:43

Ok, en la época de tu polimetro no era común tener medición de condensadores.

Bueno, ayer estuve mirando el esquema y quizá pueda saber por dónde va el problema, haz una cosa, quita físicamente R14 y R16, NO LAS PUENTEES, QUÍTALAS y prueba a ver, ya me dices si sigue igual o cambia algo.

Añado una cosa mas, entiendo que todos los puntos de GND en rosa, estan comprobados, ¿no?, para estar seguro, lo suyo es poner un punta en el GND general del conector y comprobar en modo ohmnios todos esos puntos de GND, ¿eso lo has hecho? y si es asi, ¿todos te daban menos de 1ohm?, es decir, ¿has mirado que efectivamente las GND estan todas unidas y que son practicamente 0 ohm?, es que a veces medimos en modo pitido y no nos fijamos en el valor que da la pantalla y eso es un error, el modo pitido, dependiendo de mdelo de multimetro, puede pitar con 50 ohm o mas y eso no es estar conectado directamente, asi que compruebame que FISICAMENTE TODAS las GND de la placa, estan conectadas al mismo punto de GND del conector, todas esas mediciones, deberian de ser muy proximas a 0 ohm, si alguna te da mas de 1 ohm, hay que revisar el por que de eso.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2020, 38 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
España_País_Vasco spark2k06
Demonio tercer orden
Demonio tercer orden
Mensajes: 906
Registrado: 16 Oct 2017, 10:18
Has thanked: 34 times
Been thanked: 118 times
Contactar:

Re: Tarjeta de sonido interna OPL3 ISA 8 bits

Mensaje por spark2k06 » 13 Jun 2020, 16:22

La masa a los componentes las he medido varias veces y no veo problema por ahí, entiendo a qué te refieres con muy baja resistencia. Ya me quedo con la duda, habrá que volver a repasar.

Por otro lado, he quitado una de ellas, la R16 para ver si así solo afecta a un canal y nada, sigue igual afectando a los dos. Probaré lo que he comentado de resistencia de 10K al pin de 072 que va al condensador y el otro extremo de la resistencia a masa

Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 9243
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Has thanked: 2 times
Been thanked: 184 times
Contactar:

Re: Tarjeta de sonido interna OPL3 ISA 8 bits

Mensaje por flopping » 13 Jun 2020, 19:22

Ummmm, aquí está pasando algo muy raro, haz una cosa puentea C11 y C24, o quítalos y pon un cable, a ver cómo suena la tarjeta y nos dices.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2020, 38 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
España_País_Vasco spark2k06
Demonio tercer orden
Demonio tercer orden
Mensajes: 906
Registrado: 16 Oct 2017, 10:18
Has thanked: 34 times
Been thanked: 118 times
Contactar:

Re: Tarjeta de sonido interna OPL3 ISA 8 bits

Mensaje por spark2k06 » 13 Jun 2020, 19:52

spark2k06 escribió:
13 Jun 2020, 16:22
Probaré lo que he comentado de resistencia de 10K al pin de 072 que va al condensador y el otro extremo de la resistencia a masa
Buenas noticias, lo he hecho con uno de los dos canales y ya funciona bien! Ahora cuando se pierde el sonido sólo es con el otro:

Imagen

De manera que solo tengo que agregar otra resistencia de 10K a masa para el otro condensador.

@flopping, lo que comentas de puentear los condensadores funcionaría también, pero no los tendríamos filtrando el sonido, así que mejor está así. Tengo que hacer pruebas más exhaustivas pero pinta bien.

No obstante, sigo mosca con el tema de por qué en el diseño original de la Resound OPL3 no han hecho esto y les funciona. Que podría ser alguna masa no conectada como comentas, pero no la detecto.

Responder

¿Quién está conectado?

Usuarios navegando por este Foro: Bing [Bot] y 7 invitados