[Finalizado] - Reparando y actualizando Atari STFM 1040 Alemán

Atari 520/1040 megaST

Moderador: Fundadores

Responder
Avatar de Usuario
Quickie
El infierno es su lugar
El infierno es su lugar
Mensajes: 197
Registrado: 21 Sep 2017, 19:58
Agradecido : 6 veces
Agradecimiento recibido: 6 veces
Contactar:

[Finalizado] - Reparando y actualizando Atari STFM 1040 Alemán

Mensaje por Quickie » 17 Ago 2018, 03:35

Buenas noches,

A raíz del hilo de BCH (aquí) al final me he animado y he empezado el proceso de actualización de un Atari STFM 1040 alemán que pude obtener a muy buen precio de ese país.

Éste STFM es un C103414-001 Rev. 1 y aquí una vez lo recibí, incluyendo un ratón STM1 (¡por fín se acabó tirar de "Alternate" + cursor!):

Imagen

A primera vista se ve que había un trozo de carcasa suelto...y una esquina tocada. En fin...lo abro para poder evaluar la tragedia y la cosa pinta muy mal: la carcasa superior está hecha unos zorros:

Imagen

Bueno, dejaré de momento de lado la parte estética para otro momento, ya que tengo un STE al que he sido incapaz de reparar un problema de disquetera tras cambiar el WD1772, U305 (74LS06) y cambiarle la faja de floppy que puede servir como donante para la carcasa superior. Por suerte la carcasa inferior está inmaculada.

- Tareas a realizar:

* Cambio de unidad de floppy (Epson) por una Gotek con FF
* Actualización de TOS alemán (1.02) a 1.04 ES
* Swap de teclado por otro con layout español

Bien, empecemos por la Gotek, total, ya tengo la unidad flasheada con FF (en su día lo hice con un cable USB macho - USB macho). La conecto y tiro de un USB ya preparado con juegos, elijo el primero de la lista...y ¡funciona a la primera!:

Imagen

¡Bah! esto no tiene gracia, ha sido muy facil...voy a conectar la Gotek dentro de la carcasa ya que ahora está por fuera para probar...

Imagen

¡La leche! ¡No me llega el cable de alimentación por unos 2 cm ya que la Gotek está algo desplazada! Nada...toca reciclar un conector Molex de una fuente AT que pasó a mejor vida hace muucho:

Imagen

Desueldo el antiguo conector, sueldo el nuevo dándole algo más de longitud que el original, lo brido..y nada, esto debería estar... :))

Imagen

¡¡Jaaaaaa, ni de coña!! Ahora es el turno de la faja del bus de datos del floppy. Parece que tito Tramiel no era muy derrochador:

Imagen

Madre mia, estoy empezando a cansarme del ST...pero bueno, por suerte tengo una faja de una disquetera de PC.

Imagen

Ale...ya está, conectores abiertos y cable sustituido por uno 4 cms más largo cortado a medida (Atari powered by Asus :D)

Hago una prueba y veo que ahora al arrancar en TOS, éste ni me muestra las unidades. Polímetro en mano compruebo que fallan varios pines ya que parece ser que no estaban bien ensartados (si Vlad Tepes levantara la cabeza...). El conector original de 34 pines ha quedado algo tocado y aunque repito el proceso 3 veces con tanto cortar y empalmar siempre hay algun pin que falla. Al final opto por tirar de Aliexpress y pillo un pack de 10 conectores hembra de 34 pines para soldar en placa. Cuando llegue actualizo este punto.

Pasemos al teclado. Ésto no tiene mayor misterio: swap por el teclado en castellano. Compruebo que funciona. Perfecto.

Upgrade de TOS a 1.04 (ES):

Puesto que es un STFM y no quiero liarme demasiado quiero hacer un upgrade limpio y "sencillo", por ese motivo elegí la v.1.0.4
Ésta placa tiene originalmente 2 chips de ROM con el TOS (U63 - HI) y (U67 - LO).
Como el fichero de la ROM ocupa 192 Kb, si quisiera mantener solo 2 EPROMS necesitaría 2 chips de 128 KBytes (por ej 27C010, 27C100), pero como no tengo y si tengo 6 EPROMS 27C256B voy a tirar de éstas.

Así que toca desoldar el estaño que hay en todas las pistas donde no hay zócalos para poder poner los nuevos (menudo trabajo de chinos):

Imagen

Ale, estaño sacado, ahora los sockets y actualizar las pistas que están en corto para seleccionar el tipo de ROMs (CE / A16 / A17) quitando el puente de "1M" por "256K"...

Imagen

¡Bien! Ya solo falta la parte de programación de EPROMs...

- Primero les doy un baño al UV durante 30 mins
- Realizo el split del fichero TOS con la utilidad Romsplit de Pera Putnik (aquí - la tool llamada "RomSplit")
- Ejecuto un emulador de ST en el PC (Hatari en mi caso y monto una unidad GEMDOS apuntando a una carpeta con el Romsplit y el fichero .img):

Imagen

Y ejecuto la app, eligiendo el split en 6 ficheros

Imagen

Resultado? Se crean de manera casi instantánea los 6 ficheros de las EPROMS, enumeradas como .HI0, .HI1, .HI2, .LO0, .LO1, .LO2

Programo una a una todas las EPROMs con el fantástico MiniPro...todas bien...menos la última! Device Error! Maldito Murphy!! Parece ser que tengo una EPROM cascada.
He probado de todo y no hay manera, está muerta.
Así que de momento se queda a medio hacer hasta que encuentre o compre otra 27C256B :(

Así ha quedado:

Imagen

* To do:

- Encontrar / Programar la EPROM que falta [LO2]
- Cambiar conector floppy soldado a placa por conector macho 34 pines y cable independiente de floppy
- Reparar la carcasa del ST aleman (epoxy + masilla + lija + pintarla en blanco al estilo Falcon?)
- Descansar :D

Espero no haberos dormido con el tocho!

-----

Actualizado:

Ya llegó la EPROM 27C256 que faltaba y he podido quemarla con el TL866.

Así han quedado una vez montadas y tapadas:

Imagen

Y...tacháan!! Prueba superada, aquí tenemos el rainbow fuji en todo su esplendor con textos en el idioma de Cervantes:

Imagen

Detalle del socket para acomodar un cable de disquetera independiente de 34 pines:

Imagen

Y por último el equipo ya montado (al final he optado por un mix de la parte superior de una carcasa de STE y la parte inferior original, ya que está en buen estado):

Imagen

¡Otro ST acondicionado! :D
Última edición por Quickie el 29 Ago 2018, 12:32, editado 3 veces en total.
Imagen

Avatar de Usuario
España Goody
Fundador
Fundador
Mensajes: 4329
Registrado: 31 Mar 2013, 23:02
Ubicación: En mi barrio de 1986
Agradecido : 213 veces
Agradecimiento recibido: 19 veces
Contactar:

Re: [WIP] - Reparando y actualizando Atari STFM 1040 Alemán

Mensaje por Goody » 17 Ago 2018, 08:07

Como molan estos hilos "bricomaniacos", me encanta ver como resucitáis/acicaláis los cacharros :)
Esperando la segunda parte :) :)
La càpsula del temps
El Goody de Va de Retro, Vintagenarios, RetroWiki, ZONADEPRUEBAS y Las Noches Skyperas, el resto es coincidencia ;)
Retrocosillas que busco
Mi mercadillo

Avatar de Usuario
España merlinkv
Hermano de Lucifer
Hermano de Lucifer
Mensajes: 4489
Registrado: 06 Abr 2015, 23:08
Ubicación: Madrid / Europa del Este
Agradecido : 12 veces
Agradecimiento recibido: 17 veces
Contactar:

Re: [WIP] - Reparando y actualizando Atari STFM 1040 Alemán

Mensaje por merlinkv » 17 Ago 2018, 09:19

Un gran trabajo. ¡Animo! Seguro que te queda genial :)
No sé como será la tercera Guerra Mundial. Pero sí sé como será la cuarta: Con palos y piedras.
Aquí yace un valiente, un temible adversario y un verdadero hombre de honor. Descanse en paz. 21-04-1918
Pásate por: WinUAEspañol

Jamaica BCH
Demonio tercer orden
Demonio tercer orden
Mensajes: 738
Registrado: 06 Sep 2014, 12:10
Ubicación: Barcelona
Agradecido : 4 veces
Agradecimiento recibido: 21 veces
Contactar:

Re: [WIP] - Reparando y actualizando Atari STFM 1040 Alemán

Mensaje por BCH » 18 Ago 2018, 19:25

Genial! Me viene perfecto el hilo! Tengo que hacer el cambio de ROMs en dos ST (uno aleman y otro frances)

Avatar de Usuario
Quickie
El infierno es su lugar
El infierno es su lugar
Mensajes: 197
Registrado: 21 Sep 2017, 19:58
Agradecido : 6 veces
Agradecimiento recibido: 6 veces
Contactar:

Re: [Finalizado] - Reparando y actualizando Atari STFM 1040 Alemán

Mensaje por Quickie » 29 Ago 2018, 12:33

Buenas, he actualizado el primer post y el título del mismo, ya he acabado la tarea. Espero que pueda servir a más gente :D
Imagen

Avatar de Usuario
España_Cataluña xphere
Seguidor infernal
Seguidor infernal
Mensajes: 33
Registrado: 18 Ene 2019, 09:39
Agradecido : 23 veces
Agradecimiento recibido: 11 veces
Contactar:

Re: [Finalizado] - Reparando y actualizando Atari STFM 1040 Alemán

Mensaje por xphere » 06 Feb 2019, 15:11

impresionante trabajo! bravo!!! :)
demoscene ftw!
www.xphere.me

Responder

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 0 invitados