Spectrum +2 no se enciende correctamente hasta que se calienta y falla el sincronismo vertical

¿Tienes problemas con tu equipo?, preguntanos.

Moderador: Fundadores

Avatar de Usuario
Kyp
Hermano de Lucifer
Hermano de Lucifer
Mensajes: 2556
Registrado: 30 Sep 2013, 14:54
Ubicación: Madrid
Has thanked: 43 times
Been thanked: 103 times
Contactar:

Re: Spectrum +2 no se enciende correctamente hasta que se calienta

Mensaje por Kyp » 04 Nov 2019, 19:42

Nextric escribió:
03 Nov 2019, 21:11
Una pregunta, he visto que el regulador de voltaje es un L7805CV, aparentemente presenta las mismas características que un LM78S05, pero como ya no sé por donde tirar, no sé si tendrá algo que ver. Creo que el hecho de que no ponga LM solo indica que el fabricante es distinto, ¿No?
Si, las primeras letras suelen ser para identificar el fabricante. De todas formas, si tarda en arrancar y es por voltaje puedes verlo midiendo con el polímetro, si nada más encender no hay 5V es que pasa algo.
Nextric escribió:
03 Nov 2019, 21:29
Por cierto, he desoldado la bobina L6 y da continuidad por lo que no parece que sea eso. Brrr
Las bobinas son las menos sospechosas de fallar :|

Puedes medir si en el pin de reset de la CPU (26) hay 5V. Nada más encender hay 0 y en unos milisegundos sube a 5V, para el caso al medir debería haber 5V casi instantáneamente.

Si es otra cosa ya es más difícil de detectar sin herramientas adecuadas. Lo del aire frío es una opción pero al menos un osciloscopio para ver que hay en diversos puntos va a ser casi imprescindible para no ir dando palos de ciego.

Avatar de Usuario
España Nextric
Seguidor infernal
Seguidor infernal
Mensajes: 48
Registrado: 18 Sep 2019, 13:29
Has thanked: 1 time
Been thanked: 3 times
Contactar:

Re: Spectrum +2 no se enciende correctamente hasta que se calienta y falla el sincronismo vertical

Mensaje por Nextric » 06 Nov 2019, 21:53

Bueno, pues después de cambiar todos los condensadores, y casi todos los transistores, ya por último decidí quitar el sintonizador para descartar que me estuviera metiendo ruido o algo parecido. Nada seguía igual, empecé a revisar los voltajes, y no veía nada raro, pero ya estaba empezando a dudar de todo y como soy muy cabezón seguía revisando elementos. No entendía porque era el único con este problema de imagen... Así que nada, me digo a mi mismo, que por co*ones tiene que haber algo en el cable o en el conector scart. Y mira tu por donde...., tiene huevos......., uno de los cables estaba soldado en el pin contrario al que debía..... Lo desueldo y con la manita lo acerco al pin correcto del din8 y ..... ¡¡¡Voila!!!!!
¡¡¡Ya tengo imagen clara y definida!!!
Siento mucho la que os he liado a todo el mundo intentado encontrar el fallo, aunque a cambio, he dejado tuneado el ordena en lo referente a condensadores y TR's.
Bueno, con el tema de la imagen ya controlado, se sigue produciendo el tema ya comentado de que hasta que no se calienta un rato, no comienza a funcionar adecuadamente. He entrado en el modo test, pero tengo una duda, ¿No debería de aparecer el test al pulsar las teclas "qazplm"? Porque lo he probado varias veces y nada de nada..... Bueno, entiendo que todo apunta a algún módulo de RAM, pero ya con imagen lo puedo abordar con mas entusiasmo.

Os dejo varias fotos del bicho.

Como ha quedado la placa y el conector din8 destripado:
► Mostrar Spoiler
Imagen en frío, no paran de aparecer combinaciones de cuadrados:
► Mostrar Spoiler
Una vez calentito, todo parece funcionar con normalidad, excepto lo de entrar en el menu de test avanzado:
► Mostrar Spoiler

Avatar de Usuario
Bone
Aspirante a demonio
Aspirante a demonio
Mensajes: 308
Registrado: 22 May 2017, 06:16
Has thanked: 19 times
Been thanked: 29 times
Contactar:

Re: Spectrum +2 no se enciende correctamente hasta que se calienta y falla el sincronismo vertical

Mensaje por Bone » 06 Nov 2019, 22:25

Vaya!! A @Kyp ya le olía a problema de cable!!! :D
Pues ahora toca averigurar que le pasa al cacharro que en frio no quiere chutar!

Avatar de Usuario
España Nextric
Seguidor infernal
Seguidor infernal
Mensajes: 48
Registrado: 18 Sep 2019, 13:29
Has thanked: 1 time
Been thanked: 3 times
Contactar:

Re: Spectrum +2 no se enciende correctamente hasta que se calienta y falla el sincronismo vertical

Mensaje por Nextric » 06 Nov 2019, 23:02

El caso es que he repasado todas las soldaduras, por si era eso, que al calentarse dilatara un poco e hiciera entonces buen contacto, pero nada. Aunque con la de puntos que hay alguna se puede haber escapado o ser simplemente un chip en mal estado. Seguiré investigando, la cosa es lo de no poder entrar en el test la que me tiene mosqueado. Desconozco si es que esa opción solo era válida para los +2A/+2B y +3

Avatar de Usuario
Kyp
Hermano de Lucifer
Hermano de Lucifer
Mensajes: 2556
Registrado: 30 Sep 2013, 14:54
Ubicación: Madrid
Has thanked: 43 times
Been thanked: 103 times
Contactar:

Re: Spectrum +2 no se enciende correctamente hasta que se calienta y falla el sincronismo vertical

Mensaje por Kyp » 06 Nov 2019, 23:07

Me alegro de que funcione y haya sido algo tan tonto como lo del cable :D

Lo del arranque en frío ya es más complicado. Se me ocurren dos cosas, lo primero el reset, que algo haga que se quede en reset hasta que pasa un rato (R53 y C36). Lo segundo el oscilador, lo mismo, que algo haga que no le llegue clock al Z80. Entre la ULA y el Z80 solo está IC12. Si hay señal de video en frío a la ULA si le llega su clock.

Lo del test, no estoy seguro, pero me suena a que eso solo lo tiene la ROM del +3

Avatar de Usuario
Kyp
Hermano de Lucifer
Hermano de Lucifer
Mensajes: 2556
Registrado: 30 Sep 2013, 14:54
Ubicación: Madrid
Has thanked: 43 times
Been thanked: 103 times
Contactar:

Re: Spectrum +2 no se enciende correctamente hasta que se calienta y falla el sincronismo vertical

Mensaje por Kyp » 06 Nov 2019, 23:09

Bueno, también podría ser una RAM que no funciona hasta que se calienta. Sería bueno pasarle una ROM de test en frío a ver que hace.

Avatar de Usuario
España Nextric
Seguidor infernal
Seguidor infernal
Mensajes: 48
Registrado: 18 Sep 2019, 13:29
Has thanked: 1 time
Been thanked: 3 times
Contactar:

Re: Spectrum +2 no se enciende correctamente hasta que se calienta y falla el sincronismo vertical

Mensaje por Nextric » 06 Nov 2019, 23:19

Puede ser lo que comentas Kyp, y el test solo lo tenga dicho modelo. Mañana, si me dejan un tiempo libre...., reviso la resistencia y el condensador que es lo mas sencillo de mirar. Mmmm, sobre la ROM de test en frío, ¿Donde se puede conseguir eso? ¿Con el Dandanator se puede? Es que en ese tema todavía no estoy muy puesto.... :?

Avatar de Usuario
Bone
Aspirante a demonio
Aspirante a demonio
Mensajes: 308
Registrado: 22 May 2017, 06:16
Has thanked: 19 times
Been thanked: 29 times
Contactar:

Re: Spectrum +2 no se enciende correctamente hasta que se calienta y falla el sincronismo vertical

Mensaje por Bone » 06 Nov 2019, 23:28

Sí, exactamente. Esa opción del test de memoria y toda la pesca es para las versiones "negras" del +2 y obviamente para el +3. Por cierto, ¿que tarda en calentarse y que funcione bien?

Avatar de Usuario
España Nextric
Seguidor infernal
Seguidor infernal
Mensajes: 48
Registrado: 18 Sep 2019, 13:29
Has thanked: 1 time
Been thanked: 3 times
Contactar:

Re: Spectrum +2 no se enciende correctamente hasta que se calienta y falla el sincronismo vertical

Mensaje por Nextric » 06 Nov 2019, 23:33

5 minutos o así

Avatar de Usuario
España Nextric
Seguidor infernal
Seguidor infernal
Mensajes: 48
Registrado: 18 Sep 2019, 13:29
Has thanked: 1 time
Been thanked: 3 times
Contactar:

Re: Spectrum +2 no se enciende correctamente hasta que se calienta y falla el sincronismo vertical

Mensaje por Nextric » 06 Nov 2019, 23:33

No lo he medido con exactitud

Responder

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 0 invitados