ZX Spectrum+ 48k Issue 6A averiado

Moderador: Fundadores

Avatar de Usuario
sachapr
El infierno es su lugar
El infierno es su lugar
Mensajes: 116
Registrado: 05 Feb 2015, 13:31
Contactar:

ZX Spectrum+ 48k Issue 6A averiado

Mensaje por sachapr » 15 Abr 2015, 16:22

Hola a todos,

Este es otro de los Spectrum que he adquirido recientemente que me gustaría resucitar...

Precisamente es el que le falta la tecla cambio y que comentaba en otro hilo si hay alguien que tenga repuestos y me quiera vender una para que no este mutilado...A ver si hay algun alma caritativa... :-) No me gustaría tener que ponerle una tecla "SYM" de las que llevan los modelos ingleses..

Os cuento:

Es un Issue 6A:
Issue 6A Board Front.jpg
Issue 6A Board Front
Issue 6A Board Front.jpg (297.51 KiB) Visto 631 veces
Issue 6A Board Back.jpg
Issue 6A Board Back
Issue 6A Board Back.jpg (292.38 KiB) Visto 631 veces
Veo 2 cosas que me extrañan, parece que la ROm tiene un pin fuera del zocalo y hay un cablecito que lo une con un pin de la CPU, creo, es un Integrado de NEC. Por el otro lado de la placa tambien hay un cablecito que une dos puntos.

Cuando lo enciendes aparece una pantalla con el borde blanco rayas verticales amarillas y al pulsar el reset, a veces cambia a otra con rayas amarillas, amarillas de puntitos y roja de puntitos que se mueven ligeramente.
Issue 6A Init Screen + Reset.jpg
Issue 6A Init Screen + Reset
Issue 6A Init Screen + Reset.jpg (360.45 KiB) Visto 631 veces
He medido las tensiones de -5, 5 y 12 en la memoria baja y estan correctas.

Gracias y saludos!!

Avatar de Usuario
sachapr
El infierno es su lugar
El infierno es su lugar
Mensajes: 116
Registrado: 05 Feb 2015, 13:31
Contactar:

Re: ZX Spectrum+ 48k Issue 6A averiado

Mensaje por sachapr » 15 Abr 2015, 16:25

Por cierto cuando conecto el Turbo RAM Drive con el cartucho de Paul Farrow se ve esto:
Issue 6A Init Screen Turbo RAM Drive.jpg
Issue 6A Init Screen Turbo RAM Drive
Issue 6A Init Screen Turbo RAM Drive.jpg (226.23 KiB) Visto 630 veces
y la pantalla cambia si le conecto el ZX Interface con el mismo cartucho:
Issue 6A Init Screen ZX Interface 2.jpg
Issue 6A Init Screen ZX Interface 2
Issue 6A Init Screen ZX Interface 2.jpg (101.46 KiB) Visto 630 veces
y no noto que ninguno de los ICs de la memoria baja se caliente demasiado.

Gracias y saludos!!

Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 9571
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Has thanked: 2 times
Been thanked: 264 times
Contactar:

Re: ZX Spectrum+ 48k Issue 6A averiado

Mensaje por flopping » 15 Abr 2015, 16:31

¿A que pin va conectada la EPROM con la CPU?, ya que por la foto no lo veo bien, pero creo que es el 22, bueno, pues puedes probar lo siguiente, si tienes otro ordenador, comprobar que la ULA esta bien y tambien podrias desactivar al memoria ram alta y ver si en modo 16k arranca, en principio no parece que sea la rom, asi que vamos a ir descartando cosas a ver, salu2.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2021, 39 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
sachapr
El infierno es su lugar
El infierno es su lugar
Mensajes: 116
Registrado: 05 Feb 2015, 13:31
Contactar:

Re: ZX Spectrum+ 48k Issue 6A averiado

Mensaje por sachapr » 16 Abr 2015, 10:28

Hola,
Sí, es la patilla 22.
Te voy contando si hay avances.
Gracias y saludos!!

Avatar de Usuario
sachapr
El infierno es su lugar
El infierno es su lugar
Mensajes: 116
Registrado: 05 Feb 2015, 13:31
Contactar:

Re: ZX Spectrum+ 48k Issue 6A averiado

Mensaje por sachapr » 16 Abr 2015, 13:30

Hola,

He probado la ULA en un 48k que va bien y funciona perfectamente.
No puedo desactivar la memoria alta porque es un issue 6A y no tengo resistencias de 1K. ¿Hay alguna otra forma de hacerlo sin necesidad de la resistencia?

Saludos!!

Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 9571
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Has thanked: 2 times
Been thanked: 264 times
Contactar:

Re: ZX Spectrum+ 48k Issue 6A averiado

Mensaje por flopping » 16 Abr 2015, 14:33

sachapr escribió:Hola,

He probado la ULA en un 48k que va bien y funciona perfectamente.
No puedo desactivar la memoria alta porque es un issue 6A y no tengo resistencias de 1K. ¿Hay alguna otra forma de hacerlo sin necesidad de la resistencia?

Saludos!!
Para desactivar la memoria alta, se puenteaba el pin 35 con el 40 del PCF1306.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2021, 39 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
sachapr
El infierno es su lugar
El infierno es su lugar
Mensajes: 116
Registrado: 05 Feb 2015, 13:31
Contactar:

Re: ZX Spectrum+ 48k Issue 6A averiado

Mensaje por sachapr » 16 Abr 2015, 16:54

¿Pero hace falta hacerlo con una resistencia de 1k o se puede hacer directamente con un cablecito? Porque me pareció leer lo de la resistencia en un mensaje tuyo antiguo en otro foro.

Gracias y saludos,

Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 9571
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Has thanked: 2 times
Been thanked: 264 times
Contactar:

Re: ZX Spectrum+ 48k Issue 6A averiado

Mensaje por flopping » 16 Abr 2015, 17:17

sachapr escribió:¿Pero hace falta hacerlo con una resistencia de 1k o se puede hacer directamente con un cablecito? Porque me pareció leer lo de la resistencia en un mensaje tuyo antiguo en otro foro.

Gracias y saludos,
No hace falta ninguna resistencia, con un cable se puede hacer.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2021, 39 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
sachapr
El infierno es su lugar
El infierno es su lugar
Mensajes: 116
Registrado: 05 Feb 2015, 13:31
Contactar:

Re: ZX Spectrum+ 48k Issue 6A averiado

Mensaje por sachapr » 16 Abr 2015, 21:50

He soldado un cablecito entre los pines 40 y 35 por la cara de abajo de la placa y nada...al arrancar muestra un pantalla blanca con pixeles de colores.
Saludos,

Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 9571
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Has thanked: 2 times
Been thanked: 264 times
Contactar:

Re: ZX Spectrum+ 48k Issue 6A averiado

Mensaje por flopping » 16 Abr 2015, 22:26

Pues parece que va a ser tema de la memoria baja, si tienes posibilidad de usar la rom de testeo de mcleod, quiza te de algun dato mas para saber que chip es el que esta fallando.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2021, 39 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Responder

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 0 invitados