[Solucionado] Avería 128K toastrack

Moderador: Fundadores

Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 8502
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Agradecido : 2 veces
Agradecimiento recibido: 36 veces
Contactar:

Re: Avería 128K toastrack

Mensaje por flopping » 26 Ago 2018, 23:02

Esas roms deberían de servirte, de todas formas, ahora que has quitado la rom interna, puedes probar el interface de rom externa a ver qué hace el equipo.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2018, 36 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
llopis
Demonio tercer orden
Demonio tercer orden
Mensajes: 561
Registrado: 05 Jul 2018, 09:43
Ubicación: Asturias
Agradecido : 28 veces
Agradecimiento recibido: 14 veces
Contactar:

Re: Avería 128K toastrack

Mensaje por llopis » 26 Ago 2018, 23:08

Al intentar leer la ROM con el programador de EPROM, me dio error en una patilla. Eso ya me había pasado con un Amstrad. O sea que me programé una EPROM a partir de las dos ROMs en la página esa que puse en el enlace de antes y...
Tada!
2018-08-26 23.03.07.jpg
2018-08-26 23.03.07.jpg (120.76 KiB) Visto 182 veces
Claramente todavía no está curado, pero la ROM nueva hace que saque vídeo con CPU y ROM puestos. Y además no tiene mala pinta (borde de color correcto). Ahora seguramente sí que queda uno o más chips de RAM por ahí.
Ya casi está. Pena que se me estropease el Dandanator para probarlo. Aunque ahora que lo pienso, como la ROM tiene zócalo, me puedo grabar un programa de testeo en otra EPROM.

Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 8502
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Agradecido : 2 veces
Agradecimiento recibido: 36 veces
Contactar:

Re: Avería 128K toastrack

Mensaje por flopping » 26 Ago 2018, 23:20

El sonido funciona? Probablemente no, pero compruébalo.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2018, 36 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
llopis
Demonio tercer orden
Demonio tercer orden
Mensajes: 561
Registrado: 05 Jul 2018, 09:43
Ubicación: Asturias
Agradecido : 28 veces
Agradecimiento recibido: 14 veces
Contactar:

Avería 128K toastrack

Mensaje por llopis » 26 Ago 2018, 23:29

Puse esta TestROM y el resultado es catastrófico (con sirena de alarma y todo):
2018-08-26 23.24.06.jpg
2018-08-26 23.24.06.jpg (120.76 KiB) Visto 179 veces
Cada una de esas rayas rojas es un chip de la memoria baja que falla.
No sé lo que le habrá pasado a este pobre ordenador, pero no queda mucho en pie Imagen
(También he podido ser yo que lo fastidié aún más cuanto le puse un Dandanator ayer, pero resulta que no tenía guía puesta y seguramente lo puse mal. O sea que le pude haber metido 9V por la línea de 5V y cargarme toda la memoria además de cargarme el Dandanator mismo).

Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 8502
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Agradecido : 2 veces
Agradecimiento recibido: 36 veces
Contactar:

Re: Avería 128K toastrack

Mensaje por flopping » 27 Ago 2018, 00:04

Yo ya te he dicho lo que yo haría, léete los mensajes anteriores si quieres hacer algo de eso, salu2.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2018, 36 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
llopis
Demonio tercer orden
Demonio tercer orden
Mensajes: 561
Registrado: 05 Jul 2018, 09:43
Ubicación: Asturias
Agradecido : 28 veces
Agradecimiento recibido: 14 veces
Contactar:

Re: Avería 128K toastrack

Mensaje por llopis » 27 Ago 2018, 00:11

Que sí, que me los he leído todos con mucha atención :-) Y muchas gracias por todas las ideas que has aportado.

Seguramente me mida los buses bien antes de empezar a cambiar chips a lo loco. ¿Qué tipo de resistencia tiene que haber entre los buses y 5V y 0V? Varios Mohm no?


Sent from my iPhone using Tapatalk

Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 8502
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Agradecido : 2 veces
Agradecimiento recibido: 36 veces
Contactar:

Re: Avería 128K toastrack

Mensaje por flopping » 27 Ago 2018, 00:39

No tiene por qué dar resistencias tan altas, más que comprobar la resistencia que de, lo “normal” es que todos den un valor más o menos igual, cuando digo todos no me refiero a que todos los buses midan lo mismo, si no a qué los buses de datos del Z80 deben de medir más o menos iguales entre ellos, pero no tiene por qué medir lo mismo que los buses de direcciones, aunque estos si que deberían de medir más o menos igual entre ellos, es decir, cada bus de cada chip puede dar un valor diferente, pero un mismo bus de un mismo chip, debería de dar más o menos la misma resistencia entre sus líneas, no sé si me he expresado bien o más o menos lo has entendido, espero que si, salu2.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2018, 36 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
duca750
Demonio segundo orden
Demonio segundo orden
Mensajes: 1318
Registrado: 28 Ago 2017, 13:14
Agradecido : 34 veces
Agradecimiento recibido: 25 veces
Contactar:

Re: Avería 128K toastrack

Mensaje por duca750 » 27 Ago 2018, 00:56

Qué bien ver avances aunque estés teniendo tantos problemas. Verás como con la ayuda de la gente tan maja que hay por aquí lo echas a andar. Suerte!
Mi coleccion: CPC464,CPC6128/GX4000/COMMODORE 64,AMIGA 500/ATARI STFM1024/ORIC1,ATMOS/DRAGON32/SPECTRUM+, +2,+3,48K,16K/MSX HB501P,101P,201P,MSX HB20P,HB75P,CANON V20,PHILIPS MSX2 NMS8250,8020/TOSHIBA MSX/ACORN ELECTRON/THOMSON MO08,MO05,ENTERPRISE 64.

Avatar de Usuario
llopis
Demonio tercer orden
Demonio tercer orden
Mensajes: 561
Registrado: 05 Jul 2018, 09:43
Ubicación: Asturias
Agradecido : 28 veces
Agradecimiento recibido: 14 veces
Contactar:

Re: Avería 128K toastrack

Mensaje por llopis » 28 Ago 2018, 12:39

Sigue avanzando la cosa: Resulta que a la EPROM de test que puse le pasaba algo, porque me daba resultados muy diferentes cuando lo enchufaba varias veces. La probé en un +2 y tampoco funcionaba. Creo que no lo gustó que le metiera un 27C128 en vez de un 27C256 a pesar de ser 16K.

La volví a grabar en un 27C256 y ahora las pruebas funcionan bien en los dos ordenadores. Pero claro, en el 128K fallan y me sale esto:
ramfail.jpg
ramfail.jpg (92.31 KiB) Visto 131 veces
Este es el test que estoy usando, lo que quiere decir que en teoría todas las RAM bajas están fastidiadas (aunque consigue escribir en la pantalla sin problemas). Cambio uno cualquiera (IC13 porque está en la esquina) y... me da el mismo resultado (probando con varios ICs que sé que están bien).

Ayer repasé la resistencia de los buses con las líneas de 0V y 5V, y todo parecía dentro de lo normal. Lo único un poco sospechoso es que A10 tenía una resistencia algo menor a 0V que las demás líneas del bus de direcciones (la mayoría andaban sobre los 3.2MO y A10 sobre 2.6MO).

Ahora sí que empiezo a tener mis sospechas del ZX8401, porque si ese no funcionase, sí que podría parecer que toda la memoria no está funcionando bien. ¿Qué os parece?

Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 8502
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Agradecido : 2 veces
Agradecimiento recibido: 36 veces
Contactar:

Re: Avería 128K toastrack

Mensaje por flopping » 28 Ago 2018, 12:59

Cambia el ZX8401.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2018, 36 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Responder

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 0 invitados