[arreglado] fallo en un Spectrum 48k , TR4 ardiendo

¿Tienes problemas con tu equipo?, preguntanos.

Moderador: Fundadores

Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 9241
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Has thanked: 2 times
Been thanked: 184 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por flopping » 30 Sep 2019, 21:39

Yo lo que haria seria comprobar que se generan los +12 y -5v, por lo que deberias de aislar esas dos tensiones, para ello mira el esquema y puedes cortar las pistas adecuadas o levanta la R62 de 15R y R79 de 2k2 y D19, y mide en ambos extremos de cada componente levantado a ver si se generan los voltages que necesitamos, evidentemente en un extremo no deberiamos de tener nada, pero mide de todas formas, en la linea de -5v puede que tengas mas tension, eso es normal, asi que mide a ver que sale y con lo que veamos seguimos diagnosticando.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2020, 38 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 9241
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Has thanked: 2 times
Been thanked: 184 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por flopping » 30 Sep 2019, 22:02

Te paso el esquema de la fuente para que veas donde hay que cortar o que componentes tienes que levantar, elije una de las dos opciones.
fuente.jpg
fuente.jpg (48.83 KiB) Visto 90 veces
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2020, 38 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
España ardraven
El infierno es su lugar
El infierno es su lugar
Mensajes: 127
Registrado: 21 Feb 2019, 00:51
Has thanked: 7 times
Been thanked: 9 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por ardraven » 30 Sep 2019, 22:50

Por cierto... conviene quitar la ULA para hacer todas estas pruebas , verdad?

Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 9241
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Has thanked: 2 times
Been thanked: 184 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por flopping » 30 Sep 2019, 22:54

ardraven escribió:
30 Sep 2019, 22:50
Por cierto... conviene quitar la ULA para hacer todas estas pruebas , verdad?
Pues si, todo lo que tengas en zocalo quitalo, ULA, Z80, ROM, RAM lo que sea, quita todo lo que puedas, ahora solo estamos comprobando tensiones, asi que no hay problema.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2020, 38 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
España ardraven
El infierno es su lugar
El infierno es su lugar
Mensajes: 127
Registrado: 21 Feb 2019, 00:51
Has thanked: 7 times
Been thanked: 9 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por ardraven » 30 Sep 2019, 23:03

por cierto, el 2K2 es el R29 8-)

Avatar de Usuario
España ardraven
El infierno es su lugar
El infierno es su lugar
Mensajes: 127
Registrado: 21 Feb 2019, 00:51
Has thanked: 7 times
Been thanked: 9 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por ardraven » 30 Sep 2019, 23:18

No encuentro R19... he estado buscando la placa sin componentes para poder leer dónde está esa resistencia y no la veo. El texto de R19 debe de estar debajo del componente y no lo encuentro.

Edito: aquí está el layout: https://spectrumforeveryone.com/wp-cont ... Layout.gif

Otra cosa... el 'cuadrado' con letras N y H sobre el altavoz es diferente en mi placa que en esta: http://hardware.speccy.org/imagenes/ord ... sue4B.jpg
En la mía la esquina superior izq y derecha no van soldadas a ningún sitio. Las dos inferiores están soldadas entre ellas. Si las numerásemos así:

1..2
....
....
3--4


están soldadas la 3 y 4.

Pero la de la foto que adjunto están la 1 a la 3 y la 2 a la 4...

1..2
|..|
|..|
3..4

Avatar de Usuario
Kyp
Hermano de Lucifer
Hermano de Lucifer
Mensajes: 2794
Registrado: 30 Sep 2013, 14:54
Ubicación: Madrid
Has thanked: 79 times
Been thanked: 257 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por Kyp » 30 Sep 2019, 23:45

ardraven escribió:
30 Sep 2019, 23:18
Otra cosa... el 'cuadrado' con letras N y H sobre el altavoz es diferente en mi placa que en esta: http://hardware.speccy.org/imagenes/ord ... sue4B.jpg
En la mía la esquina superior izq y derecha no van soldadas a ningún sitio. Las dos inferiores están soldadas entre ellas. Si las numerásemos así:
Eso depende de la marca de la ROM:
N = NEC
H = Hitachi o GI o Sinclair...

Pero deberías tener dos puentes, los dos N o los dos H.

Avatar de Usuario
España_Comunidad_Valenciana flopping
Fundador
Fundador
Mensajes: 9241
Registrado: 29 Mar 2013, 15:26
Ubicación: Valencia
Has thanked: 2 times
Been thanked: 184 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por flopping » 30 Sep 2019, 23:59

ardraven escribió:
30 Sep 2019, 23:03
por cierto, el 2K2 es el R29 8-)
Cierto, en la 4B es R29, en la 4A es R79

ardraven escribió:
30 Sep 2019, 23:18
No encuentro R19... he estado buscando la placa sin componentes para poder leer dónde está esa resistencia y no la veo. El texto de R19 debe de estar debajo del componente y no lo encuentro.


Nadie a dicho nada de R19, es D19 el diodo zener de 5v.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, por la esquizofrenia paranoide que padezco.
(C) 1982-2020, 38 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente".

Avatar de Usuario
España ardraven
El infierno es su lugar
El infierno es su lugar
Mensajes: 127
Registrado: 21 Feb 2019, 00:51
Has thanked: 7 times
Been thanked: 9 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por ardraven » 01 Oct 2019, 00:14

Kyp escribió:
30 Sep 2019, 23:45
ardraven escribió:
30 Sep 2019, 23:18
Otra cosa... el 'cuadrado' con letras N y H sobre el altavoz es diferente en mi placa que en esta: http://hardware.speccy.org/imagenes/ord ... sue4B.jpg
En la mía la esquina superior izq y derecha no van soldadas a ningún sitio. Las dos inferiores están soldadas entre ellas. Si las numerásemos así:
Eso depende de la marca de la ROM:
N = NEC
H = Hitachi o GI o Sinclair...

Pero deberías tener dos puentes, los dos N o los dos H.
Eso es lo que me mosquea... que alguna ez haya funcionado con un único puente... lleva una EPROM NEC

Voltajes que he medido... no soy electrónico y no sé muy bien lo que estoy haciendo... negro al negativo de la entrada de alimentación (el interior, como aquí http://markmorton.co.uk/images/pr_vregtop.png ):

R29: 0.4v izquierda y 5v derecha
R62: 0.9v izquierda y 3.6v derecha
D19: izquierda cae a 0v y al quitar tensión, sube a -3v y vuelve a caer a 0v, 0.0v derecha



No lo he dejado más de unos segundos con tensión porque TR4 se sigue calentando

Avatar de Usuario
España ardraven
El infierno es su lugar
El infierno es su lugar
Mensajes: 127
Registrado: 21 Feb 2019, 00:51
Has thanked: 7 times
Been thanked: 9 times
Contactar:

Re: fallo en un Spectrum 48k , TR4 ardiendo

Mensaje por ardraven » 01 Oct 2019, 00:16

flopping escribió:
30 Sep 2019, 23:59
ardraven escribió:
30 Sep 2019, 23:18
No encuentro R19... he estado buscando la placa sin componentes para poder leer dónde está esa resistencia y no la veo. El texto de R19 debe de estar debajo del componente y no lo encuentro.


Nadie a dicho nada de R19, es D19 el diodo zener de 5v.
No me hagas caso, se me fue el dedo. Quería decir que no encontraba R29 y en su lugar puse R19 por error.

Responder

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado